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16 Saving Data

16.1Saving Your Data

You can save all or part of a capture file. You can also load a previously saved capture file,
and save a portion of that file to another file. This feature is useful if someone else needs to
see only a portion of the data in your capture file.

On the Control toolbar you can set up to capture a single file or series of files. Click here to
see those settings.

There are two ways to save portions or all of the data collected during a data capture. Click
here to see how to capture data.

16.2Saving the Entire Capture File using File > Save or the Save
icon

This option is only available when you select Single File from the Capture Mode on System
Settings. Click here to learn more about selecting Save options from System Settings.

1. Ifyouare capturing data, click on the Stop icon to stop data capture. You cannot
save data to file while it is being captured.

3. Click the Save icon, or select Save from the File menu.

2. Open the Event Display or Frame Display window.
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Type a filename in the File name box at the bottom of the screen.

Browse to select a specific directory. Otherwise your file is saved in the default capture
file directory.

When you are finished, click OK.

16.3Saving the Entire Capture File with Save Selection
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If you are capturing data, click on the Stop icon to stop data capture. You cannot

save data to file while it is being captured.

E| window.

Open the Event Display or Frame Display

Right click in the data

Select Save Selection or Save As from the right click menu

Save
() Endits Fie
) Events (%) Frames

1 b 1
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Click on the radio button labeled Entire File.

Choose to save Events or Frames. Choosing to save Events saves the entire contents of
the capture file. Choosing to save Frames does not save all events in the capture file.

Type a filename in the Save As box at the bottom of the screen. Click the Browse icon to
browse to a specific directory. Otherwise your file is saved in the default capture file
directory.

When you are finished, click OK.
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16.4Saving a Portion of a Capture File

=

If you are capturing data, click on the Stop icon to pause data capture. You cannot
save data to a file while it is being captured.

Open the Event Display fﬁ or Frame Display window EI, depending on whether you
want to specify a range in bytes or in frames.

Select the portion of the data that you want to save. Click and drag to select data, or click
on the first item, move to the last item and Shift+Click to select the entire range, or use
the Shift key with the keyboard arrows or the navigation icons in the Frame Display
toolbar. If the range you want to save is too large to select, note the numbers of the first
and last item in the range.

Right click in the data

Select Save Selection or Save As from the right click menu

Save 0
() Entite Fila
(%) Selechin L

) Events (%) Frames

1 by 11
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file is being sarved.

Click on the radio button labeled Selection. If you selected a range, make sure the
starting and ending numbers are correct. To specify a range, type the numbers of the
first and last items in the range in the boxes.

Select either Events or Frames to indicate whether the numbers are event or frame
numbers.

Type a filename in the Save As box at the bottom of the screen. Click the Browse icon to
browse to a specific directory. Otherwise your file is saved in the default capture file
directory.

Click OK when you are finished.

16.5Confirm Capture File (CFA) Changes

This dialog appears when you close a capture file after changing the Notes, the protocol
stack, or bookmarks. The dialog lists information that was added or changed and allows you
to select which information to save, and whether to save it to the current file or to a new

one.
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Changes made to the file appear in a list in the left pane. You can click on each item to see
details in the right pane about what was changed for each item. You simply check the boxes
next to the changes you want to keep. Once you decide what changes to keep, select one of
the following:

e Save To This File - Saves the changes you have made to the current capture file.

e Save As - Saves the changes to a new file.

e Cancel the Close Operation - Closes the file and returns you back to the display. No
changes are saved.

e Discard Changes - Closes the file without saving any of the changes made to the
notes, bookmarks, or protocol stack.

16.6 Adding Comments to a Capture File

The Notes feature allows you to add comments to a CFA file. These comments can be used
for many purposes. For example, you can list the setup used to create the capture file,
record why the file is useful to keep, or include notes to another person detailing which
frames to look at and why. (Bookmarks are another useful way to record information about
individual frames.)

To open the Notes window :

1. Click the Show Notes icon LH . This icon is present on the toolbars of the Frame Display

EI, the Protocol Navigator @ , as well as the Event Display & . Notes can be
selected from the Edit menu on one of these windows.

2. Type your comments in the large edit box on the Notes window. The Cut, Copy, Paste,
Undo and Redo features are all supported.

3. Click the thumbtack icon -

to keep the Notes window on top of any other windows.
4. When you're done adding comments, close the window.

5. When you close the capture file, you are asked to confirm the changes to the capture file.

See Confirming Capture File (CFA) Changes for more information.
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17 Loading and Importing Capture Files

17.1Loading a Capture File

From the Control Window:
1. Go to the File menu.
2. Choose afile from the recently used file list.

3. Ifthe file is not in the File menu list, select Open Capture File from the File menu or

simply click on the Open icon on the Toolbar.
4. Capture files have a .cfa extension. Browse if necessary to find your capture file.

5. Click on your file, and then click Open.

17.2Importing Capture Files

1. From the Control Window ‘@, go to the File menu and select Open Capture File or click
on the Open icon on the Toolbar.

2. Change the Files of Type box to All Importable File Types or All Supported File Types.
Select the file and click Open.

The analyzer automatically converts the file to the analyzer's format while keeping the
original file in its original format. You can save the file in the analyzer's format, close the file
without saving it in the analyzer's format, or have the analyzer automatically save the file in
the analyzer's format (see the System Settings to set this option). All of these options keep
your original file untouched.

When you first open the file, the analyzer brings up the Protocol Stack window and ask you
what protocol decodes, if any, you want to use. You must choose a protocol decode at this
point for the analyzer to decode the data in the file. If you open a file without using any
decodes, and decide later that you want to apply a decode, choose Reframe from the File
menu on the Control window.

At present, the analyzer supports the following file types:

e Frontline Serialtest* Async and Serialtest ComProbe® for DOS - requires the
byt for data and the .tim for timestamps (see note on importing DOS timestamps).

e Greenleaf ViewComm* 3.0 for DOS - requires the .byt for data and the .tim for
timestamps (see note on importing DOS timestamps).

¢ Frontline Ethertest* for DOS - requires 3 files: filename.cap, filename.ca0 and
filename.cal.

e Sniffer Type 1 - supports files with the .enc extension. Does not support Sniffer
files with a .cap extension.
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e Snoop or Sun Snoop - files with a .cap extension based on RFC 1761. For file
format, see http://www.fags.org/rfcs/rfc1761.html.

e Shomiti Surveyor files in Snoop format - files with a .cap extension. For file
format, contact Technical Support.

e CATC Merlin - files with a .csv extension. Files must be exported with a specific
format. See File Format for Merlin Files for information.

e CATC Chief - files with a .txt extension.

17.3Converting Timestamps

Serialtest for DOS uses a timebase of Pacific Standard Time during non daylight savings time
hours and Pacific Daylight Time during daylight savings time hours. The analyzer always
uses Greenwich Mean Time (also known as Universal Time Coordinates).

When importing a Serialtest for DOS file, the analyzer must determine if the file was
recorded during daylight savings time or not before converting the timestamps. Because the
rules for determining this can change, it is possible for the analyzer to convert the
timestamps incorrectly, resulting in timestamps that are off by one hour.

17.4 Adding Comments to a Capture File

The Notes feature allows you to add comments to a CFA file. These comments can be used
for many purposes. For example, you can list the setup used to create the capture file,
record why the file is useful to keep, or include notes to another person detailing which
frames to look at and why. (Bookmarks are another useful way to record information about
individual frames.)

To open the Notes window :

1. Click the Show Notes icon L]J . This icon is present on the toolbars of the Frame Display

EI, the Protocol Navigator @ , as well as the Event Display & . Notes can be
selected from the Edit menu on one of these windows.

2. Type your comments in the large edit box on the Notes window. The Cut, Copy, Paste,
Undo and Redo features are all supported.

3. Click the thumbtack icon - to keep the Notes window on top of any other windows.
4. When you're done adding comments, close the window.

5. When you close the capture file, you are asked to confirm the changes to the capture file.
See Confirming Capture File (CFA) Changes for more information.
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17.5File Format for Merlin Files

FTS imports Merlin’s export files that have been exported with Merlin’s default settings.
These files should have an extension of ".csv".

It is possible with the Merlin software to hide or change a field’s format. If you do this
before exporting the Merlin file then FTS may have trouble importing the file.

If you are experiencing problems importing Merlin files, then check to make sure that no
fields were hidden and that the default field formats were being used, when the file was
exported from Merlin.
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18 Printing

18.1Printing from the Frame Display/HTML Export

The Frame Display Print dialog and the Frame Display HTML Export are very similar. This
topic discusses both dialogs.

The Frame Display Print dialog is directly below. The Frame Display HTML Export is
located midway in this discussion.

About Frame Display Print

The Frame Display Print feature provides the user with the option to print the entire
capture buffer or the current selection. When Print Preview is selected, the output displays
in a browser print preview window, where the user can select from the standard print
options. The output file format is in html, and uses the Microsoft Web Browser Control print
options for background colors and images (see below).

Print Background Colors Using Internet Explorer
1. Open the Tools menu on the browser menu bar
2. Select “Internet Options...” menu entry.
3. Click Advanced tab.
4. Check “Print background colors and images” under the Printing section
5

Click the Apply button, then click OK

Configure the Print File Range in the Frame Display Print Dialog

Selecting more than one frame in the Frame Display window defaults the radio button in the
Frame Display Print dialog to Selection and allows the user to choose the All radio button.
When only one frame is selected, the All radio button in the Frame Display Print dialog is
selected.

How to Print Frame Display Data

1. Select Print or Print Preview from the File menu on the Frame Display window to display
the Frame Display Print dialog. Select Print if you just want to print your data to your
default printer. Select Print Preview if you want access to printer options.

2. Choose to include the Summary Pane (check the box) in the print output. The summary
Pane appears at the beginning of the printed output in tabular format. If you select All
layers in the Detail Section, the Data Bytes option becomes available.

3. Inthe Detail Section, choose to exclude the decode from the Detail Pane in the Frame
Display, or include All Layers or Selected Layers Only. If you choose to include selected
layers, then select (click on and highlight) the layers from the list box. Click on selected
layers in the list to de-select, or click the Reset button to de-select all selected layers.
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CAUTION: Decode layers printout expanded regardless of the state of the Detail
Pane in the Frame Display at the time of the request to print. This can produce a
print output consisting of hundreds of pages or more. We recommend that you

use Print Preview to determine the number of pages in your print output prior to

printing.
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Select the range of frames to include All or Selection in the Frame Range section of the
Frame Display Print dialog.

Choosing All prints all of the frames in the capture file or buffer. If more than 1000 frames
in the Frame Range, All will be disabled. You can still select more than 1000 frames using
the Selection option, but when printing more than 1000 frames, there is the possibility that
Print will not work properly.

Choosing Selection prints only the frames you select in the Frame Display window.

Note: Selecting the Delete File deletes the temporary html file that was used
during printing..

4. Click the OK button.

If you chose Print Preview, the system displays your data in a browser print preview display
with options for printing such as page orientation and paper size. You can also use your
Printer Preferences dialog to make some of these selections. When printing your data, the
analyzer creates an html file and prints the path to the file at the bottom of the page. This
file can be opened in your browser, however, it may appear different than the printed
version.
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18.2Frame Display HTML Export

The Frame Display HTML Export feature provides the user with the option to export the
entire capture buffer to an .html file.

How to export display data to an .html file

1. Select HTML Export from the File menu on the Frame Display window to display the
Frame Display HTML Export.
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2. Choose to include the Summary Pane (check the box) in the .html output. If you select
All layers in the Detail Section, the Data Bytes option becomes available.

3. Inthe Detail Section, choose to exclude the decode from the Detail Pane in the Frame
Display, or include All Layers or Selected Layers Only. If you choose to include selected
layers, then select (click on and highlight) the layers from the list box. Click on selected
layers in the list to de-select, or click the Reset button to de-select all selected layers.

4. Select the range of frames to include All or Selection in the Frame Range section of the
dialog.

Choosing Selection includes only the frames you select in the Frame Display window.

Note: If the file size is too big, the Frame Range, All, will not be available. It will be grayed
out.

5. Click the OK button.

235



frontline

Debug Communications Faster! M

The Save As dialog appears.
21
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6. Enter a name for the file you want to save.

Note: There is no need to choose a file type. The file is saved as a .htm.
7. Select Save

The file is saved as a .htm file in the file location you chose.

18.3Printing from the Event Display

About Event Display Print

The Event Display Print feature provides the user with the option to print either the entire
capture buffer or the current selection. When Print Preview is selected, the output displays
in a browser print preview window where the user can select from the standard print
options. The output file format is in html, and uses the Microsoft Web Browser Control print
options for background colors and images (see below).
Print Background Colors Using Internet Explorer

1. Open the Tools menu on the browser menu bar
Select “Internet Options...” menu entry.

Click Advanced tab.

Check “Print background colors and images” under the Printing section

ik W

Click the Apply button, then click OK
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The Event Display Print feature uses the current format of the Event Display as specified by
the user.

Note: See About Event Display for an explanation on formatting the Event Display prior to
initiating the print feature.

Configure the Print File Range in the Event Display Print Dialog

Selecting more than one event in the Event Display window defaults the radio button in the
Event Display Print dialog to Selection and allows the user to choose the All radio button.
When only one event is selected (can’t have None selected), the All radio button in the Event
Display Print dialog is selected.

How to Print Event Display Data to a Browser

1. Select Print or Print Preview from the File menu on the Event Display window to display
the Event Display Print dialog. Select Print if you just want to print your data to your
default printer. Select Print Preview if you want access to printer options.

2. Select the range of events to include from either All or Selection in the Event Range
section of the Event Display Print dialog. Choosing All prints all of the events in the
capture file or buffer. Choosing Selection prints only the selected events in the Event
Display window.

Note: In order to prevent a Print crash, you cannot select All if there are
more than 100,000 events in the capture buffer.

Note: See Configure the Print File Range in the Event Display Print Dialog above for an
explanation of these selections
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3. Click the OK button.

If you chose Print Preview, the system displays your data in a browser print preview display
with options for printing such as page orientation and paper size. You can also use your
Printer Preferences dialog to make some of these selections. When printing your data, the
analyzer creates an html file and prints the path to the file at the bottom of the page. This
file can be opened in your browser, however, it may appear different than the printed
version.
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18.4Print Preview

Print Preview gives a preview of how the data looks printed. You can scroll through the
pages and zoom in on the data to get a closer look. The line of buttons across the top of the
window controls the functions of the window.

To open the Print Preview window:
1. Choose Print Preview from the File menu in any window that supports printing.

2. Choose to include the Summary Pane (check the box) in the print output. The summary
Pane appears at the beginning of the printed output in tabular format. If you select All
layers in the Detail Section, the Data Bytes option becomes available.

3. Inthe Detail Section, choose to exclude the decode from the Detail Pane in the Frame
Display, or include All Layers or Selected Layers Only. If you choose to include selected
layers, then select (click on and highlight) the layers from the list box. Click on selected
layers in the list to de-select, or click the Reset button to de-select all selected layers.

CAUTION: Decode layers printout expanded regardless of the state of the Detail Pane in the
Frame Display at the time of the request to print. This can produce a print output consisting
of hundreds of pages or more. We recommend that you use Print Preview to determine the
number of pages in your print output prior to printing.

|
Irchide Detad Sechon
W Sagnrmaiy F Mo decods saction
o AN bpers
" Selected lapers ony
Frame Fange
& BOZ1D il
* A B2
 Selection AR CSP
B PCCC
ARP
Ll -0 B ;I
I Dabsin Fils |

Mote: Beowser pard ophions may alfect whether ang
ey backgiound it parted. Ses Help foe nfa

ok | caesl | Hep |

4. Select the range of frames to include All or Selection in the Frame Range section of the
Frame Display Print dialog.

Choosing All prints all of the frames in the capture file or buffer. If there are more than

1000 frames in the capture file or buffer, All will not be available.

Choosing Selection prints only the selected frames in the Frame Display window.

Note: See Configure the Print File Range in the Frame Display Print Dialog above for an
explanation of these selections.
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Note: Selecting the Delete File deletes the temporary html file that was used
during printing..

5. Click the OK button.

You can print directly from the Print Preview window.
e Next Page shows you how the next page in your data looks
e Prev Page takes you back to the previous page.

e Two Page changes the display to show two pages of data. When in the Two Page
display, the button reads One Page. Click on the One Page button to return to
viewing one page.

e Zoom In and Zoom Out allow you to change the magnification of the pages. Click on
Zoom In to increase the magnification, and on Zoom Out to decrease the
magnification. When you have reached the limit in either direction, the buttons is
grayed out.

e You can also zoom in and out by clicking on the page itself. When the cursor looks
like a magnifying glass, you can click on the page to increase the magnification.
When you have reached the top level of magnification, the cursor changes back to an
arrow. Click on the page to return to normal magnification.

e Click on the Close button to return to the regular display.
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19 Exporting

19.1Export

You can dump the contents of the Summary pane on the Frame Display into a Comma
Separated File (CSV).

To access this feature:
1. Right click on the Summary Pane
2. Select the Export menu item
3. Enter a file name
4

Select Save

Another option to access quick export is :

1. Click on the File menu
2. Choose Export

3. Enter a file name
4

Select Save

19.2Export Filter Out

You can filter out data you don't want or need in your text file.

(This option is available only for serial data.) In the Filter Out box, choose which side to
filter out: the DTE data, the DCE data or neither side (don't filter any data.) For example, if
you choose the radio button for DTE data, the DTE data would be filtered out of your export
file and the file would contain only the DCE data.

You can also filter out Special Events (which is everything that is not a data byte, such as
control signal changes and Set [/0 events), Non-printable characters or both. If you choose
to filter out Special Events, your export file would contain only the data bytes. Filtering out
the non-printable characters means that your export file would contain only special events
and data bytes classified as printable. In ASCI], printable characters are those with hex
values between $20 and $7e.
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19.3Exporting Event Display to a File

About Event Display Export

The Event Display Export feature provides the following options:
e Export either the entire capture buffer or the current selection
e OQutput file format as text, CSV, html, or bin.

The Event Display Export feature uses the current format of the Event Display as specified
by the user.

Note: See About Event Display for an explanation on formatting the Event Display prior to
initiating the export feature.

Accessing the Event Display Export Dialog

Selecting Export Events... from the File menu in the Event Display brings up the following
dialog:
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Configure the Export File Range in the Event Display Export Dialog

e Selecting more than one event in the Event Display window defaults the radio
button in the Event Display Export dialog to Selection and allows the user to choose
the All radio button.

e When only one event is selected (something must be selected), the All radio button
in the Event Display Export dialog is selected by default.

e Sideis used to determine whether you want to export data from a DCE/DTE,
Slave/Master, Host/Function device or both.
How to Export Event Display Data to a File

1. Select Export Events... from the File menu on the Event Display window to display the
Event Display Export dialog.

2. Enter afile path and name, or click the browser button to display the Windows Save As
dialog and navigate to the desired storage location.
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Select a file type from the Save as type: drop-down List Menu on the Event Display
Export dialog.

Select from among the following file formats:

Text File (*.txt)
CSV File (*.csv)

HTML File (*html)

Binary File (*.bin)

Select the range of events to include in the file from either All or Selection in the Event
Range section of the Event Display Export dialog.

Note: See Configure the Export File Range in the Event Display Export Dialog above for
an explanation of these selections.

Select a Side, either Host, Function, or Both

Click Save.

19.4Exporting Baudot

When exporting Baudot, you need to be able to determine the state of the shift character. In
a text export, the state of the shift bit can be determined by the data in the Character field.
When letters is active, the character field shows letters and vice versa.

19.5HTML Export

The Frame Display HTML Export feature provides the user with the option to export the
entire capture buffer to an .html file.

How to export display data to an .html file

Select HTML Export from the File menu on the Frame Display window to display the
Frame Display HTML Export.
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2. Choose to include the Summary Pane (check the box) in the .html output. If you select
All layers in the Detail Section, the Data Bytes option becomes available.

3. Inthe Detail Section, choose to exclude the decode from the Detail Pane in the Frame
Display, or include All Layers or Selected Layers Only. If you choose to include selected
layers, then select (click on and highlight) the layers from the list box. Click on selected
layers in the list to de-select, or click the Reset button to de-select all selected layers.

4. Select the range of frames to include All or Selection in the Frame Range section of the

dialog.

Choosing Selection includes only the frames you select in the Frame Display window.

Note: If the file size is too big, the Frame Range, All, will not be available. It will be grayed

out.

5. Click the OK button.

The Save As dialog appears.
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6. Enter a name for the file you want to save.

Note: There is not need to choose a file type. The file is saved as a .htm.

7. Select Save
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20 System Settings and Program Options

20.1System Settings

Open the System Settings window by choosing System Settings from the Options menu on
the Control window. To enable a setting, click in the box next to the setting to place a
checkmark in the box. To disable a setting, click in the box to remove the checkmark. When
viewing a capture file, settings related to data capture are grayed out.
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Capture Mode
e Series of files

This option lets you capture to a series of files. The size of each file is no larger than
the number given in File Size (in K),which has a maximum limit of approximately
176,000KB (1.7 GB) or 1/2 of the available hard disk space, whichever is smaller.
The name of each file is the name you give it in the Name box followed by the date,
time and a number. The date and time are when the series was opened. The number
increments with each file. This guarantees unique file names are created.

Set the maximum number of files in the series in the Maximum number of files box.
The next file starts when the currently open file is full. If you want to start a new file
on a periodic basis, check the box for Start new file after and put in the number of
hours after which a new file is started. Note that if the currently open file becomes
full before the time limit has been reached, a new file is opened immediately rather
than lose data.

Capturing stops if the maximum number of files has been used unless Wrap Files has
been checked. If Wrap Files has been checked the analyzer erases the oldest file in
the series and make a new file.
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o Single File

This option allows the analyzer to capture data to a file without prompting you for a
file name each time. The size of each file is not larger than the number given in File
Size (in K). The name of each file is the name you give it in the Name box followed by
the date and time. The date and time are when the series was opened.

Common Options
¢ Restart Capturing After Saving or Clearing Capture File

If the Automatically Restart feature is enabled, the analyzer restarts capture to the
file immediately after the file is closed.

Wrap File
When enabled, the analyzer wraps the file when it becomes full. The oldest events are
moved out of the file to make room for new events. Any events moved out of the file
are lost. When disabled, the analyzer stops capture when the file becomes full. Either
reset the file or close your capture file to continue.

e File Size (in K)
Enter the maximum size of the capture file, which is 176,000 KB, or 1/2 of the

available hard drive space, whichever is smaller. If you enter a number larger than
the maximum allowable size, the analyzer will display the allowable size.

¢ Default
Enter a name for the capture file in the Default text box. Each saved file will begin
with this name.

e Append Series Start/Date & File Number
Select this radio button to automatically append a start date (yyyy-mm-dd_hhmmss)
and file number (001) when capturing a series of files.

e Append File Start Date/Time
Select this radio button to automatically append a start date (yyyy-mm-dd_hhmmss)
when capturing a single file.

e Startup

Opens the Program Start up Options window. Start up options let you choose
whether to start data capture immediately on opening the analyzer.

e Advanced

Opens the Advanced System Options window. The Advanced Settings should only be
changed on advice of technical support.
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20.2System Settings - Disabled/Enabled Options

Some of the System Settings options are disabled depending upon the status of the data
capture session.

e Asthe default, all the options on the System Settings dialog are enabled.

e Once the user begins to capture data by selecting the Start Capture button, some of
the options on the System Settings dialog are disabled until the user stops data
capture and either saves or erases the captured data.

e The user can go into the Startup Options and Advanced System Options on the
System Settings dialog and make changes to the settings at any time.

20.3Advanced System Options

These parameters affect fundamental aspects of the software, and it is unlikely that you
ever have to change them. If you do change them and need to return them to their original
values, the default value is listed in parentheses to the right of the value box.

Most technical support problems are not related to these parameters, and as changing them
could have serious consequences for the performance of the analyzer, we strongly
recommend contacting technical support before changing any of these parameters.

To access the Advanced System Options:

1. Go to the Control @ window.
2. Choose System Settings from the Options menu.

3. On the System Settings window, click the Advanced button.

e Driver Receive Buffer Size in Kbytes

This is the size of the buffer used by the driver to store incoming data. This value is
expressed in Kbytes.

e Driver Action Queue Size In Operating System Pages

This is the size of the buffer used by the driver to store data to be transmitted. This
value is expressed in operating system pages.

e Frame Completion Timeout in Seconds

This is the number of seconds that the analyzer waits to receive data on a side while
in the midst of receiving a frame on that side.

If no data comes in on that side for longer than the specified number of seconds, an
"aborted frame" event is added to the Event Display and the analyzer resumes
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decoding incoming data. This can occur when capturing interwoven data (DTE and
DCE) and one side stops transmitting in the middle of a frame.

Aborted frames (just like broken frames and regular frames) are decoded and
displayed in the Frame Display. If you experience aborted frames and suspect that
your framed data may have pauses in it that exceed the specified timeout time, then
you may want to increase that value.

The range for this value is from 0 to 999,999 seconds. Setting it to zero disables the
timeout feature.

Note: This option is disabled when capturing data over Ethernet networks.

20.4 Changing Default File Locations

The analyzer saves user files in specific locations by default. Capture files are placed in the
My Capture Files directory and configurations are put in My Configurations. These locations
are set at installation.

Follow the steps below to change the default locations.

1. Choose Directories from the Options menu on the Control @ window to open the File
Locations window.

2. Select the default location you wish to change.
3. Click Modify.

4. Browse to a new location.

5. Click OK.

6. Click OK when finished.

Note: If a user sets the My Decoders directory such that it is up-directory from an
installation path, multiple instances of a personality entry may be detected, which causes a
failure when trying to launch FTS. For example, if an FTS product is installed at C:\FTS
Stuff\My Products\Frontline FTS4BT w.x.y.z, then "My Decoders" cannot be set to any of
the following:
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C:\

C:\FTS Stuff

C:\FTS Stuff\My Products

C:\FTS Stuff\My Products\Frontline FTS4BT w.x.y.z

C:\FTS Stuff\My Products\Frontline FTS4BT w.x.y.zZ\App Data

C:\FTS Stuff\My Products\Frontline FTS4BT w.x.y.zZ\App Data\Decoders
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e or to any directory that already exists under C:\FTS Stuff\My Products\Frontline
FTS4BT w.x.y.zZ\App Data\Decoders

Default Capture File Folder Checkbox

If the “Use Last Opened Folder for Capture Files” checkbox is checked, then the system
automatically changes the default location for saving capture files each time you open a file
from or save a file to a new location. For example, let's say the default location for saving
capture files is Drive A > Folder A. Now you select the “Use Last Opened Folder for
Capture Files” checkbox. The next time, however, you open a capture file from a different
location, Folder B > Removable Flash Drive. Now when you save the capture file, it will
be saved to Folder B > Removable Flash Drive. Also, all subsequent files will be saved to
that location. This remains true until you open a file from or save a file to a different
location.

There is one caveat to this scenario, however. Let's say you have selected "Use Last Opened
Folder for Capture Files" and opened a file from a location other than the default directory.
All subsequent capture files will be saved to that location. Suppose, however, the next time
you want to save a capture file, the new file location is not available because the directory
structure has changed: a folder has been moved, a drive has been reassigned, a flash drive
has been disconnected, etc. In the case of a "lost" directory structure, subsequent capture
files will be saved to the default location. FTS will always try to save a file to the folder
where the last file was opened from or saved to, if “Use Last Opened Folder for Capture
Files” is checked. If, however, the location is not accessible, files are saved to the default
directory that is set at installation.

If the checkbox is unchecked, then the system always defaults to the directory listed in the
File Locations dialog.

20.5Selecting Start Up Options

1. To open this window:

2. Choose System Settings from the Options menu on the Control @ window.
3. On the System Settings window, click the Start Up button.

4. Choose one of the options to determine if the analyzer starts data capture immediately
on starting up or not.

Don't start capturing immediately.

This is the default setting. The analyzer begins monitoring data but does not begin

capturing data until the Start Capture & icon on the Control, Event Display or Frame
Display windows is clicked.

Start capturing to a file immediately.
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When the analyzer starts up, it immediately opens a capture file and begin data capture to

it. This is the equivalent of clicking the Start Capture @ icon. The file is given a name
based on the settings for capturing to a file or series of files in the System Settings window.
Start capturing immediately to the following file:

Enter a filename in the box below this option. When the analyzer starts up, it immediately
begins data capture to that file. If the file already exists, the data in it is overwritten.

Use this capture filter:

The drop down box lists all named filters. Select one that you want to use immediately on
start up.

20.6 Names

The Names dialog is used to change the names of objects and events that appear in various
displays.

1. To open the Names dialog, choose Names from the Options menu on the Control
window. Changes to the Names are used throughout the program.

To change a name, click on the name given in the current column, and then click again to
modify the name (a slow double-click). To restore the default values, click the Defaults
button. The names used in the system fall into one of three general categories.

Because of variations associated with different types of communications, the Names dialog
may display all or only a subset of the following categories:

e Sides

The Sides section allows you to give each side on a network more descriptive names.
This is useful on network with more than one side.

e Errors

This section allows you to change the error names. The errors listed are appropriate
for the type of circuit/network you are monitoring.

e Signals

Signals refers to the six control signals used in RS-232 data communications, and
may not apply to the type of communications you are monitoring.

FTS4USB has four Control Signals: Pin 1, Pin 2, Pin 3, and Pin 4.
Default Labels and their Meaning
Label Control Signal

RTS Request to Send

CTS Clear to Send
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DSR Data Set Ready

DTR Data Terminal Ready
CD Carrier Detect

RI Ring Indicator

If you are used to different abbreviations for the same signals, you can change them
in this section. For example, if you normally refer to Carrier Detect as DCD, highlight
CD and type in DCD.

20.7 Timestamping

20.7.1 Timestamping Options

The Timestamping Options window allows you to enable or disable timestamping, and
change the resolution of the timestamps for both capture and display purposes.

To open this window:
1. Choose System Settings from the Options menu on the Control window.

2. Click the Set Timestamp Format button.

OR

1. Click the Timestamping Options icon from either the Event Display or Statistics
window.

OR

1. Click the Timestamping Options icon from the Event Display window.
20.7.2 Enabling/Disabling Timestamping

1. Choose System Settings from the Options menu on the Control window, and click the

Timestamping Options button, or click the click the Timestamping Options icon

from either the Event Display ¢ or Statistics H] window.

2. Check the Store Timestamps box to enable timestamping. Remove the check to disable
timestamping. If you disable timestamping, you are not able to do delta or rate
calculations.
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20.7.3 Switching Between Relative and Absolute Time
With Timestamping you can choose to employ Relative Time or Absolute time.

1. Choose System Settings from the Options menu on the Control window, and click the

i)

Timestamping Options button, or click the click the Timestamping Options icon ‘

from either the Event Display ¢ or Statistics H] window.

2. Go to the Display Options section at the bottom of the window and find the Display
Relative Timestamps checkbox.

3. Check the box to switch the display to relative timestamps. Remove the check to return
to absolute timestamps.

Note: The options in this section affect only how the timestamps are displayed on the screen,
not how the timestamps are recorded in the capture file.

e Display Raw Timestamp Value shows the timestamp as the total time in hundred
nanoseconds from a specific point in time.

e Display Relative Timestamps shows the timestamp as the amount of time that has
passed since the first byte was captured. It works just like a stop watch in that
the timestamp for the first byte is 0:00:00.0000 and all subsequent timestamps
increment from there. The timestamp is recorded as the actual time, so you can flip
back and forth between relative and actual time as needed.

e Selecting both values displays the total time in nanoseconds from the start of the
capture as opposed to a specific point in time.

e Selecting neither value displays the actual chronological time.

When you select Relative Timestamp, you can set the number of digits to display using the
up or down arrows on the numeric list.

20.7.4 Changing the Timestamping Resolution

This option affects the resolution of the timestamp stored in the capture file. The default
timestamp is 10 milliseconds. This value is determined by the operating system and is the
smallest "normal” resolutions possible.
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It is also possible to use "high resolution" timestamping. High resolution timestamp values
are marked by an asterisk as high resolution in the drop down list. To change timestamping
resolutions:

1. Choose System Settings from the Options menu on the Control @ window, and click

the Timestamping Options button, or click the click the Timestamping Options icon

from either the Event Display & or Statistics H] window.

2. Go to the Capture Options section of the window.

3. Change the resolution listed in the Storage Resolution box. Note that if you change the
resolution, you need to exit the analyzer and restart in order for the change to take
effect.

20.7.5 Displaying Fractions of a Second

1. Choose System Settings from the Options menu on the Control @ window, and click

the Timestamping Options button, or click the click the Timestamping Options icon

from either the Event Display ¢ or Statistics H] window.
2. Go to the Display Options section at the bottom of the window, and find the Number of
Digits to Display box.

3. Click on the arrows to change the number. You can display between 0 and 6 digits to the
right of the decimal point.

The options in this section affect only how the timestamps are displayed on the screen, not
the resolution used to capture the data.

20.7.6 Converting Timestamps

Serialtest for DOS uses a timebase of Pacific Standard Time during non daylight savings time
hours and Pacific Daylight Time during daylight savings time hours. The analyzer always
uses Greenwich Mean Time (also known as Universal Time Coordinates).

When importing a Serialtest for DOS file, the analyzer must determine if the file was
recorded during daylight savings time or not before converting the timestamps. Because the
rules for determining this can change, it is possible for the analyzer to convert the
timestamps incorrectly, resulting in timestamps that are off by one hour.
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20.7.7 Performance Issues For High Resolution Timestamps

There are two things to be aware of when using high resolution timestamps. The first is that
high resolution timestamps take up more space in the capture file because more bits are
required to store the timestamp. Also, more timestamps need to be stored than at normal
resolutions. The second issue is that using high resolution timestamping may affect
performance on slower machines

For example, if 10 bytes of data are captured in 10 milliseconds at a rate of 1 byte per
millisecond, and the timestamp resolution is 10 milliseconds, then only one timestamp
needs to be stored for the 10 bytes of data. If the resolution is 1 millisecond, then 10
timestamps need to be stored, one for each byte of data. If you have two capture files, both
of the same size, but one was captured using normal resolution timestamping and the other
using high resolution, the normal resolution file has more data events in it, because less
room is used to store timestamps.

You can increase the size of your capture file in the System Settings.
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21 Technical Information

21.1Contacting Technical Support

Technical support is available in several ways. The online help system provides answers to
many user related questions. Frontline's website has documentation on common problems,
as well as software upgrades and utilities to use with our products.

On the Web: http://www.fte.com/support/default.asp

Email: tech support@fte.com

If you need to talk to a technical support representative, support is available between 9am
and 5pm, U.S. Eastern time, Monday through Friday. Technical support is not available on
U.S. national holidays.

Phone: +1 (434) 984-4500
Fax: +1 (434) 984-4505

21.2Asynchronous Serial Performance Notes

As a software-based product, the speed of your computer’s processor affects FTS’s
performance. Overrun errors and buffer overflows are indicators that FTS is unable to keep
up with the data. The information below describes what happens to the data as it comes in
the port, what the two types of errors mean, and how various aspects of FTS affect
performance. Also included are suggestions on how to improve performance.

Data captured by the serial port first goes into the buffer of the UART chip of the serial port.
The UART generates an interrupt, which tells the FTS driver to check the port. The driver
takes the data from the UART and counts each byte as they are put into the driver’s own
buffer. The driver tells FTS that data is ready to be processed. FTS takes the data from the
driver’s buffer and puts the data into the capture buffer.

Overrun errors occur when the data in the buffer of the UART is not retrieved before new
data comes in. In this case, FTS knows that it has lost information, but it does not know how
much. FTS indicates overrun errors in the Event Display screen by marking a byte near the
overrun in red. You can search for overrun errors using the Find feature.

Driver buffer overflow errors occur when the data in the buffer of the driver is not retrieved
before new data comes in. Since the driver counts the bytes as it retrieves them from the
UART, it not only knows that it has lost data, it also knows how much. Buffer overflows are
indicated in the Event Display screen by a plus sign within a circle. Clicking on the buffer
overflow symbol shows how many events have been lost. The Statistics window is a good
place to check for buffer overflow errors.
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Both overrun errors and buffer overflows indicate that data is coming in too quickly for FTS
to process. There are several things that you can do to try and solve this problem.

In the Hardware Settings window, select Use Windows Device Manager Settings. This
means that Windows does not generate an interrupt every time a byte comes in, but
rather waits until several bytes have accumulated in the UART buffer before telling
FTS to retrieve them. This increases performance at the cost of timestamp accuracy,
since all the bytes in a group have the same timestamp regardless of when they
actually arrived at the UART. Some control signal changes may also be lost.

FTS’s number one priority is capturing data; updating windows is secondary.
However, updating windows still takes a certain amount of processor time, and may
cause FTS to lose data while the window is being updated. Some windows require
more processing time than others, because the information being displayed in them
is constantly changing. Refrain from displaying data live in the Event Display and
Frame Display windows. Try closing the Breakout Box and Statistics windows. FTS
can capture data with no windows other than the Control window open.

Increase the value of the window refresh rate for any windows you have open while
capturing data. This decreases the frequency of window updates, leaving more time
for capturing data. Changing the refresh rate can be done from the Options screen
in each window.

If you suspect or know that your circuit has control signals that are changing very
rapidly, go to the Hardware Settings window and choose to Disable Control Signal
Interrupts. This prevents FTS from capturing control signal changes on an interrupt
basis, giving more time for capturing byte data. (You can use the counters in the
Breakout Box to help determine if a control signal is changing quickly.) FTS still
notes the state of the control signals whenever a byte is captured. You must restart
FTS for this change to take effect.

Close all other programs that are working while FTS is running. Refrain from doing
searches in the Event Display window or other processor intensive activities while
FTS is capturing data.

Timestamping takes up processor time, primarily not in timestamping the data, but
in writing the timestamp to the buffer or file. Try turning off timestamping from the
Timestamping Options window.

Change the size of the driver buffer. This value is changed from the Advanced
System Settings. Go to the Control Window and choose System Settings from the
Options menu. Click on the Advanced button. Find the value labeled Driver Receive
Buffer Size in Operating System Pages. Take the value listed there and double it.

NOTE: This procedure might help buffer overflow errors, but does not
help overrun errors.

Slow down the speed of the communications circuit, if possible.

If you are still experiencing overruns and/or buffer overflows after trying all of the above
options, then you may need to use a faster PC.
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21.3Changing Where the Search Lands

When doing a search in the analyzer, the byte or bytes matching the search criteria are
highlighted in the Event Display. The first selected byte appears on the third line of the
display.

To change the line on which the first selected byte appears:
1. Open fts.ini (located in the C:\Program Files\Common Files\FTE)
2. Go to the [CVEventDisplay] section
3. Change the value for SelectionOffset.
4

If you want the selection to land on the top line of the display, change the
SelectionOffset to 0 (zero).

21.4Progress Bars

The analyzer uses progress bars to indicate the progress of a number of different processes.
Some progress bars (such as the filtering progress bar) remain visible, while others are
hidden.

The title on the progress bar indicates the process underway.

21.5Event Numbering

This section talks about how events are numbered when they are first captured and how
this affects the display windows in the analyzer. The information in this section applies to
frame numbering as well.

When the analyzer captures an event, it gives the event a number. If the event is a data byte
event, it receives a byte number in addition to an event number. There are usually more
events than bytes, with the result is that a byte might be listed as Event 10 of 16 when
viewing all events, and Byte 8 of 11 when viewing only the data bytes.

The numbers assigned to events that are wrapped out of the buffer are not reassigned. In
other words, when event number 1 is wrapped out of the buffer, event number 2 is not
renumbered to event 1. This means that the first event in the buffer may be listed as event
11520 of 16334, because events 1-11519 have been wrapped out of the buffer. Since row
numbers refer to the event numbers, they work the same way. In the above example, the
first row would be listed as 2d00 (which is hex for 11520.)

The advantage of not renumbering events is that you can save a portion of a capture file,
send it to a colleague, and tell your colleague to look at a particular event. Since the events
are not renumbered, your colleague’s file use the same event numbers that your file does.
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21.6File Format for Merlin Files

FTS imports Merlin’s export files that have been exported with Merlin’s default settings.
These files should have an extension of ".csv".

It is possible with the Merlin software to hide or change a field’s format. If you do this
before exporting the Merlin file then FTS may have trouble importing the file.

If you are experiencing problems importing Merlin files, then check to make sure that no
fields were hidden and that the default field formats were being used, when the file was
exported from Merlin.

21.7Ring Indicator

The following information applies when operating the analyzer in Spy mode or Source DTE,
No FTS Cables mode. When using the cables supplied with the analyzer to capture or source
data, Ring Indicator (RI) is routed to a different pin which generates interrupts normally.

There is a special case involving Ring Indicator and computers with 8250 UARTs or UARTSs
from that family where the state of RI may not be captured accurately. Normally when a
control signal changes state from high to low or low to high, an interrupt is generated by the
UART, and the analyzer goes to see what has changed and record it. Ring Indicator works a
little differently. An interrupt is generated when RI changes from high to low, but not when
RI changes from low to high. If Ring Indicator changes from low to high, the analyzer does
not know that RI has changed state until another event occurs that generates an interrupt.
This is simply the way the UART works, and is not a deficiency in the analyzer software.

To minimize the chance of missing a Ring Indicator change, the analyzer polls the UART
every millisecond to see if RI has changed. It is still possible for the analyzer to miss a Ring
Indicator change if RI and only RI changes state more than once per millisecond.

UARTS in the 8250 family include 8250s, 16450s, 16550s and 16550 variants. If you have
any questions about the behavior of your UART and Ring Indicator, please contact technical
support.

21.8RS-232 Pin-outs

25-pin connector

Pin Name Abbreviation
1 Frame Ground FG

2 Transmit Data TxD

3 Receive Data RxD

4 Request To Send RTS
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9-pin connector

Clear to Send

Signal Ground

Data Terminal Read

CTS

GND

DTR
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Pin

Name

Abbreviation

1

Carrier Detect

Transmit Data

Signal Ground

Request To Send

Ring Indicator

CD or DCD

TxD

GND

RTS

RI

2

(@)}

1
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21.9Useful Character Tables

21.9.1 ASCII Codes

hex| =0 | =1 | «2

x3 | xd | x5 | ub | %7 | %B | »3 | xA | xB | xC | x0 | xE | *F
Dx_| NUL|SOH| ST | ET# |EQT|ENQ|ACK|BEL| BS | HT | LF [VT | FF | CR| SO S
1x |OLE|DCT[DC2|DC3| DC4 | NAKISYN| ETB|CAN| EM |SUB|ESC| FS | GS | RS | US
2 [SP[ 1 BEIEEETEYE [ ¥ * o+, - . /
x| O [ 1 21 3|45 5 7 8 9 . ; £ | = > 7
sl @ (Al B|JCIDIEJFIGIH]I]JJ]KILIMIN|Q
xlPplolrRISITIUlvIw]| XY ] Z][[v]]]*
bx | a b | e | d 8 f q h i i kK I | m| n o
x|l p | g | s | t u v | w | x ¥y z { | } | ~ |DEL

21.9.2 Baudot Codes

[DEC [ HEX | LETIERS | FIGURES
0 | 00 |BLANK MNUL)| BLANK (NULY
1| m E 3
2 | a2 LF LF
EIGE] A
4 | 04 5P SP
5 | 05 S BEL
& | 06 1 B
7 | o7 ] 7
8 | 08 CR CR
9 | m D f
10 | 0A R 1
11 | 0B J :
12 | OC N .
13 | 0D F !
14 | OE C :
i5 | OF K {
16 0 T 5
17 1 Fi -
R EE L )
19 | 13 W 2
| 20 | 14 H #
71 | 15 Y 5
22 | 16 G 0
3| 17 Q 1
| 24 | 18 Q g
25 | 19 =] H
% | 1A G L
27 | 18 | FIGURES | FIGURES
| 28 | 1 M
2 | 10 ¥ i
30 | 1E W E
31 | IF | LETIERS | LETIERS
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21.9.3 EBCDIC Codes

hex| %0 | x1 | x2 | %3 [ =4 | x5 | «B | »7 [ »B | »9 | xA | xB | xC | xD | xE [ xF
Ox | NUL|SOH| STX)ETE| PF | HT | LC [DEL SMM YT [FF | CR (S0 5

1 IDLE(DCI1IDC2) TM [RES| ML IBS | IL |CANIEM | CC |CUT|IFS | 1GS ) IRS | IUS
25 | DS |S0%| FS BYP| LF |ETEB[ESC SM | CLU2 ENG|ACK|BEL
3 SYN PN | RS | UC |EOT CL3| DC4 | NAK SUB
4x | SP . < [ +

Iy | & | - 2 | ; "

Bx | - [ | , | % » 7

T # | @& = "

S a | blc|d]| e flaglh i

Ox i k | m | n o | p | g r

A n 5 t u W X ¥ z |

Bx 1

Ca | | AlBIC|IDIEJIF|]GI|H I

D«| 1 |J |l K| L|M| N|lD|P|@QI|R

Ex | % S| TlUlVIWwW|X|Y ]I

Fex| O 1 21 3[4 |56 |7 |89

21.9.4 Communication Control Characters
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Listed below in alphabetical order are the expanded text meanings for common ANSI
communication control characters, and two-character system abbreviation for each one.
Some abbreviations have forward slash characters between the two letters. This is to
differentiate the abbreviations for a control character from a hex number. For example, the
abbreviation for Form Feed is listed as F/F, to differentiate it from the hex number FF.

Abbreviation Control Text
Character

AK ACK Acknowledge

BL BEL Bell

BS BS Backspace

CN CAN Cancel

CR CR Carriage
Return

D/1-4 DC1-4 Device
Control 1-4

D/E DEL Delete

DL DLE Data Link
Escape

EM EM End of
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EQ ENQ Enquiry

ET EOT End of
Transmission

E/C ESC Escape

E/B ETB End of
Transmission
Block

EX ETX End of Text

F/F FF Form Feed

FS FS File
Separator

GS GS Group
Separator

HT HT Horizontal
Tabulation

LF LF Line Feed

NK NAK Negative
Acknowledge

NU NUL Null

RS RS Record
Separator

SI SI Shift In

SO SO Shift Out

SH SOH Start of
Heading

SX STX Start of Text

SB SUB Substitute

SY SYN Synchronous
Idle
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UsS UsS Unit
Separator
VT VT Vertical
Tabulation
21.10 The Serial Driver
21.10.1 The FTS Serial Driver

FTS uses custom versions of the standard Windows serial drivers in order to capture data.
These drivers are usually installed during the routine product installation. However, if you
need to install the serial driver after FTS has already been installed, please refer to the
instructions available in the Setup folder installed under Start | Programs | [Product Name
and version #] | Setup | How to Install the FTS Serial Driver.

21.11 Frame Decoder

Frame Decoder is for the development of add-on components to extend the functionality of
your FTS protocol analyzer. Those add-on components are generally used to decode
existing or custom protocols. The core of each such “decoder” is a program that defines how
the protocol data are to be broken up into fields and displayed in the Frame Display window
of the analyzer software. The DecoderScript Manual provides instruction on how to create
custom decoders and use them just like any of the decoders supplied with the protocol
analyzer. You can also apply this knowledge to modify decoders supplied with the protocol
analyzer.

For more information about Frame Decoder, consult the DecoderScript Manual located in
the desktop folder under Optional Components, or simply select Start [ Programs | Frontline
[Product Name and Version Number] | Optional Components | DecoderScript Manual.
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22 Index
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A2DP Decoder Parameters - 40
About Display Filters - 213
About Statistics - 147
Absolute Time - 254
Absolute Timestamp Search - 207
Active Devices - 157
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Modbus

Modbus TCP - 36, 37, 38, 39
Modem Lead Names - 252
Modem Leads - 20, 143
Modify Display Filters - 219, 220
Monitoring - 30, 31
Multiple Event Displays - 109
Multiple Frame Displays - 122

(0]

Open - 109

Open Capture File - 229
Options - 141, 146, 161, 251, 253
Override Decode Information - 53
Overriding Frame Information - 102
Overrun Errors - 21

N

Named Filters - 223
Names - 252
NetDecoder 1784-U2DN IO Settings Start Triggers - 85
Network Bytes Sent - 166
Network Bytes Sent Totals - 167
Network View Dashboard - 181
Define Authorized IP Addresses - 188
Show IP Addresses Seen - 189
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Add - 36
Delete - 37
Modify - 37
Node Assignment Template - 38, 39
Add - 38
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R
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