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Searching for Frame Errors

There are several options for error searching:

e Search for All Errors finds frame errors as well as frames with byte-level errors (such as
parity or CRC errors).

e Search for Frame Errors Only finds Frame specific errors, such as Frame Check errors.
e Search for Information Frame only searches Information Frames
To access the search within decodes function:

1. Select Find from the Edit menu on the Frame Display, Event Display, or the Protocol

Navigator. You may choose to select the Find icon ﬂﬂ from one of the toolbars
2. Click on the Decode tab of the Find dialog.

3. Click the appropriate radio button for the type of search you want to perform or enter a
value

4. Click Find Next.
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Note:

The tabs displayed on the Find dialog depend on the product you are running and the content of
the capture file you are viewing.

Searching for Special Events

The analyzer inserts or marks events other than data bytes in the data stream.

For example, the analyzer inserts start-of-frame and end-of-frame markers into framed data,
marking where each frame begins and ends. If a hardware error occurs, the analyzer shows this
using a special event marker.

To access the search for special events function:

1. Select Find from the Edit menu on the Frame Display, Event Display, or the Protocol

]

Navigator. You may choose to select the Find icon from one of the toolbars

2. Click on the Special Events tab of the Find dialog.
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3. Check the event or events you want to look for in the list of special events.
4. Click Find Next.

Note:

The tabs displayed on the Find dialog depend on the product you are running and the content of
the capture file you are viewing.

¢ Not all special events are relevant to all types of data. For example, control signal
changes are relevant only to serial data and not to Ethernet data.

For a list of all special events and their meanings, see List of All Event Symbols.

Searching within Decodes

Searching within decodes lets you to do a string search on the data in the Decode Pane of the
Frame Display window.

You can search one or both sides of the circuit, and your search can include wildcards. You can
use characters, hex or binary digits, wildcards or a combination of any of the formats when
entering your string.

To access the search within decodes function:

1. Select Find from the Edit menu on the Frame Display, Event Display, or the Protocol

]

Navigator. You may choose to select the Find icon from one of the toolbars.

2. Click on the Decode tab of the Find dialog.
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Note:

The tabs displayed on the Find dialog depend on the product you are running and the content of
the capture file you are viewing.

Changing Where the Search Lands

When doing a search in the analyzer, the byte or bytes matching the search criteria are
highlighted in the Event Display. The first selected byte appears on the third line of the display.

To change the line on which the first selected byte appears:
1. Open fts.ini (located in the C:\Program Files\Common Files\FTE)
2. Go to the [CVEventDisplay] section
3. Change the value for SelectionOffset.
4

If you want the selection to land on the top line of the display, change the
SelectionOffset to 0 (zero).

Entering Search Patterns (String Searches)
Searching by Pattern

Search by Pattern lets you perform a traditional string search. You can combine any of the
formats when entering your string, and your search can include wildcards.

To access the search by pattern function:

1. Select Find from the Edit menu on the Frame Display, Event Display, or the Protocol

Navigator. You can also click the Find icon ﬂﬂ from one of the toolbars.

2. Click on the Pattern tab of the Find dialog.

Decode | Patten | Time | GoTo| Special Events | Bookmark

Binasy values as &bbbbbbbb
Control characters as “c
? matches any byte, or hex of binary digit
To enter $8°7 ar \, prefic with character \

Pattern: b Find Hext
Enter:  Hex valuss as S [lgnore case
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Note:

The tabs displayed on the Find dialog depend on the product you are running and the content of
the capture file you are viewing.

Entering Characters

Various characters are used when creating a search string on the Find dialog. You can enter any
character from a character set, with the following exceptions: \$&”?. These characters are used
as prefixes to let you to enter hex, binary, control or wildcard characters.

1. Place the cursorin the Pattern box and type in your string.
2. Click Find Next in order to find the next occurrence of the string.

3. Click on Find Next as many times as necessary until the analyzer has searched all the
data.

4. Clicking on Find Previous searches the buffer backwards.

The escape character is the backslash \. Use this character when you want to search for one of
the above restricted characters. For example, to search for a $, you enter\$. To search for a ),
enter \\.

Check Ignore Case to do a case-insensitive search.
Entering Hex or Binary

Hex or Binary values are used when creating a search string on the Find dialog.

To enter a hex value :

1. Enter a$ followed by two hex digits.

2. For example, to search for hex 00 01, enter $S00501.
3. If you need to specify the $ as a character, use \S.
4

The $ symbol tells the analyzer that the following characters are hex digits

To enter a binary value:

e The & symbol tells the analyzer that a binary number comes next. For example, to
search for binary 00001111, you would use &00001111.

e If you need to specify the & as a character, use \&.
Control Characters
Various control characters are used when creating a search string on the Find dialog. You can

enter any character from a character set, with the following exceptions: \S&"?. These characters
are unavailable. The ” (caret) is used to enter the control characters Ctrl-A through Ctrl-Z and
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Ctrl-@,[,\,],- when using the ASCII character set. For example, A specifies Ctrl-A (501) and *@
specifies ASCII NUL ($00).

If you need to specify the » as a character, use \".

Note that neither the ” character nor control characters exist in Baudot, so attempts to search
for the ” character results in an error message. The * character exists in EBCDIC, but control
characters do not. A search for ~A in EBCDIC matches any occurrence of AA (S5FSC1). You do not
need to use the escape character to search for a * character in EBCDIC.

Wildcard Character

A wildcard can be used when creating a search string on the Find dialog.

The wildcard character is the question mark (?). The analyzer supports wildcard searching at the
byte, nibble and bit level. Wildcards can be used in place of characters, hex digits, and binary
digits. If you need to search for a ?, you can use \?.

Examples of Search Strings

To search for any single byte in the range of hex $10 through S$1F, type $1°?.

&1111117?7? searches for binary numbers beginning with 111111 and ending with any
combination of 1 and 0. 11111100, 11111101, 11111110, and 11111111 are all strings that
match the search criteria.

To search for any four character string which starts with an L and ends with an ES, type L?ES.

You can combine formats in one string. For example, another way to specify a search for the

Searching by Time

The analyzer can search by time in two different ways.
e Absolute

An absolute timestamp search means that the analyzer searches for an event at the
exact date and time specified. If no event is found at that time, the analyzer goes to the
nearest event either before or after the selected time, based on the "Go to the
timestamp" selection.

e Relative

A relative search means that the analyzer begins searching from whatever event you are
currently on, and search for the next event a specific amount of time away.

Note that the analyzer skips some special events that do not have timestamps, such as frame
markers. Data events that do not have timestamps because timestamping was turned off either
before or during capture are also skipped.
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To access the search by time function:

1. Select Find from the Edit menu on the Frame Display, Event Display, or the Protocol

Navigator. You may choose to select the Find icon Eﬂ from one of the toolbars.

2. Click on the Time tab of the Find dialog.

3. Use the "Search for" radio buttons at the top of the dialog to indicate the search type

EEX
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Note:

The tabs displayed on the Find dialog depend on the product you are running and the content of
the capture file you are viewing.

Searching with Absolute Timestamp

To access the search by time function:

1. Select Find from the Edit menu on the Frame Display, Event Display, or the Protocol

Navigator. You may also select the Find icon ﬂﬂ from one of the toolbars

2. Click on the Time tab of the Find dialog.

1/8/2008 Page 68 MeshDecoder-UM-002



frontlineg

* Fing A

Decods | Pattesrs). Teme | Go To | Specisl Events | Bookmark

(=) Abobte
Search i =

ORelatve 00
e o
e =
Day Hear Mirube Second 11000000 Seconds
21 @11 =l [z = s =) [ea000 -

Geo by then imersdiaeng
(%} On ox before the speciied tme
3 O o alter the speciied time

Note: The tabs displayed on the Find dialog depend on the product you are running and the
content of the capture file you are viewing.

3. Specify the time to search for by using the counters in the middle of the window.

Click on the arrows next to each item to increase or decrease the value of each counter.

By default, the counters display the timestamp of the first event in the buffer

4. After selecting the time, click on the Go To button to start the search.

Sometimes there can be more than one event with the same timestamp. The system highlights
all events with the specified timestamp.

Searching with Relative Timestamp

To access the search by time function:

1. Select Find from the Edit menu on the Frame Display, Event Display, or the Protocol

Navigator. You can also select the Find icon Eﬂ from one of the toolbars.

2. Click on the Time tab of the Find dialog.

1/8/2008 Page 69 MeshDecoder-UM-002



frontlineg

¥ Find g@@

Dacods | Pattsen| Tme | GoTo| Specisl Events | Emor | Bookmask

Search for g:b“““ Enestarng Mave Forvead
Month ol

Dy Hour Mirnte Second 11000000 Seconds
- - L - *
G by e tieer s arep

(%) O o befoes the speciied tme relstie 1o the fist selected tem
() Oroe ates the specified time relative bo the Last selected bem

Tenedamp of Frst Byte of Cunerd Selecton
V0262007 17:44:21. 400000 Ak

For Help Press F1

Note: The tabs displayed on the Find dialog depend on the product you are running and the
content of the capture file you are viewing.

3. Click on the event in the Event Display window that you want to begin the search from.
The event must have a timestamp in order for relative timestamp search to work.

4. Inthe Find dialog, use the counters in the middle of the window to specify the time
interval you want to jump.

You can specify intervals in days, hours, minutes, seconds, and fractions of a second, or any
combination of these.

5. When you have specified the time interval you want to use, click on the Move Forward
or Move Backward buttons to start the search from the current event.

For example, to search for an event occurring 10 seconds after the currently selected event,
choose to do a relative timestamp search, use 10 seconds for your time interval, and click on
Move Forward.

As with absolute timestamping, the analyzer highlights all events with the specified timestamp.

Choosing "On or Before" or "On or After"

The analyzer searches for an event that matches the time specified. If no event is found at the
time specified, the analyzer goes to the nearest event either before or after the specified time.
Choose whether to have the analyzer go to the nearest event before the specified time or after
the specified time by clicking the appropriate radio button in the "Go to the timestamp" box.
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If you are searching forward in the buffer, you usually want to choose the "On or After" button.
If you choose the "On or Before" option, it may be that the analyzer finishes the search and not
move from the current byte, if that byte happens to be the closest match.

Subtleties of Timestamp Searching

Timestamping can be turned on and off while data is being captured. As a result, the capture
buffer may have some data with a timestamp, and some data without. When doing a search by
timestamp, the analyzer ignores all data without a timestamp.

Bookmarks

Bookmarks are a way of marking frames or events of interest in a capture file. You can search for
bookmarks and move quickly between bookmarks.

Bookmarks appear as a magenta triangle next to the frame number in the Frame Display
window. Any comment associated with the bookmark appears in the Bookmark column.

When you add or change a bookmark, you are asked if you want to save your changes when you
close the capture file, and given the option of saving the bookmarks to the current file or to a
new one. See Confirming CFA Changes for more information.

Adding, Modifying or Deleting a Bookmark

You can Add, Modify, or Delete a Bookmark from the Add Bookmark dialog from the Frame
Display, Event Display, or the Protocol Navigator.
Add:

1. Select the frame or event you want to bookmark.

2. Select Add or Modify Bookmark from the Edit menu on the Frame Display, Event Display,
or the Protocol Navigator. Or simply select the Add or Modify Bookmark Ell icon on
one of the toolbars.

3. Inthe dialog box, add a comment if you wish.

4. Click OK.

Add Bookmark

Bookmark for event 1637144

i Comments Hese IE

You can also add a bookmark by right-clicking on the frame and choosing Add Bookmark from
the right-click menu.
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Modify and Delete:

1. Select the frame or event with the bookmark to be edited.

2. Select Add or Modify Bookmark from the Edit menu on the Frame Display EI, Event
Display ﬁ , or the Protocol Navigator . Or simply select the Add or Modify

Bookmark E’l icon on one of the toolbars.
3. To modify a bookmark, change the comment in the dialog box and click OK.

4. To delete a bookmark, click the Delete button.

AddiModily Bookmark

Bookmak fos event H3760421

udd Comments Heee

i

You can also modify or delete a bookmark by right-clicking on the frame and choosing Modify
Bookmark from the right-click menu.

Displaying All and Moving Between Bookmarks

There are two ways to move between bookmarks.

1. Press the F2 key to move to the next frame or event with a bookmark.

2. Click the Display All Bookmarks icon u . Select the bookmark you want to move to
and click the Go To button, or simply double-click on the bookmark. Click the Move
Forward and Move Back buttons to cycle through the bookmarks.

(1] Find CBX

Decods | Patterm | Time | GoTo| Specis Events| Bockmark
IR L L

e To delete a bookmark, select it and click the Delete button.

e To modify a bookmark, select it and click the Modify button.
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e Click Remove All to delete all the bookmarks.

Filtering
Including and Excluding Radio Buttons

All filter dialog boxes contain an "Include" and an "Exclude" radio button. These buttons are
mutually exclusive. The "Include/Exclude" selection becomes part of the filter definition, and
appears as part of the filter description displayed to the right of the Toolbar.

Include:

A filter constructed with the "Include" button selected, returns a data set that includes frames
that meet the conditions defined by the filter and omits frames that do not.

Exclude:

A filter constructed with the "Exclude" button selected, returns a data set that excludes frames
that meet the conditions defined by the filter and consists of frames that do not.

Display Filters
About Display Filters

Display filters allow a user to look at a subset of captured data without affecting the capture
content. There are three general classes of display filters:

e Protocol Filters
e Named Filters

e Quick Filters

Protocol Filters

Protocol filters test for the existence of a specific single layer. The system creates a protocol
filter for each decoder that is loaded if that layer is encountered in a capture session.

There are also three special purpose filters that are treated as protocol filters:
e All Frames with Errors
e All Frames with Bookmarks

e All Special Information Nodes

Named Filters

Named filters test for anything other than simple single layer existence. Named filters can be
constructed that test for the existence of multiple layers, field values in layers, frame sizes, etc.
as well as combinations of those things. Named filters have persistence across sessions.

Named filters are user-defined. User-defined filters persist in a template file. User defined filters
can be deleted.
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Quick Filters

Quick Filters are combinations of Protocol Filters and/or Named Filters that are displayed on the
Quick Filter tab. Quick Filters cannot be saved and do not persist across sessions. Quick Filters
are created on the Quick Filter Dialog or through filter selection on the Protocol Navigator.

Creating a Display Filter

There are two steps to using a display filter. Define the filter conditions, and then apply the filter
to the data set. The system combines both filter definition and application in one dialog.

1. Click the Display Filters icon ? on either the Protocol Navigator or the Frame

Display @window or select Apply/Modify Display Filters from the Filter menu to open
the Set Condition dialog box.

2. Select the initial condition for the filter from the drop-down list.

3. Set the parameters for the selected condition in the fields provided. The fields that
appear in the dialog box are dependent upon the previous selection. Continue to enter
the requested parameters in the fields provided until the condition statement is
complete.

4. Click OK. The system displays the Save Named Condition dialog. Provide a name for the
filter condition or accept the default name provided by the system and click OK.
Prohibited characters are left bracket '[', right bracket ']' and equal sign '='. The Set
Condition dialog box closes, creates a tab on the Frame Display with the filter name, and
applies the filter.

When a display filter is applied, a description of the filter appears to the right of the toolbar in
both the Protocol Navigator and the Frame Display windows.

Notes:

The system requires naming and saving of all filters created by the user.

The OK button on the Set Condition dialog box is unavailable (grayed out) until the condition
selections are complete.

Using Compound Display Filters

Compound filters use Boolean logic to create complex and precise filters. There are three
primary Boolean logic operators: AND, OR, and NOT.

The AND operator narrows the filter, the OR operator broadens the filter, and the NOT operator
excludes conditions from the filtered results. Include parentheses in a compound filter to nest
condition sets within larger condition sets, and force the filter-processing order.

There are two steps to using a compound filter. Define the filter conditions, and then apply the
filter to the data set. The analyzer combines both filter definition and application in one dialog.
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1. Click the Display Filters icon ? on either the Protocol Navigator or the Frame Display
window or select "Apply/Modify Display Filters" from the filter menu to open the Set
Condition dialog box.

2. Click the Advanced button on the Set Condition dialog box.
Select the initial condition for the filter from the combo box.

4. Set the parameters for the selected condition in the fields provided. The fields that
appear in the dialog box are dependent upon the previous selection. Continue to enter
the requested parameters in the fields provided until the conditions statement is
complete.

5. Click the Plus icon ﬂ on the left side of the dialog box and repeat steps 3 and 4 for the
next condition. Continue adding conditions until your filter is complete.

6. Include parentheses as needed and set the Boolean operators.

7. Click OK. The system displays the Save Named Condition dialog. Provide a name for the
filter condition or accept the default name provided by the system and click OK. The Set
Condition dialog box closes, creates a tab on the Frame Display with the filter name, and
applies the filter.

When a display filter is applied, a description of the filter appears to the right of the toolbar in
both the Protocol Navigator and the Frame Display windows.

Note:

Use the Up ﬂand Down ﬂarrow icons on the left side of the dialog box to order your

conditions, and the Delete button ﬂ to delete conditions from your filter.

The OK button on the Set Condition dialog box is unavailable (grayed out) until the condition
selections are complete.

Defining Node and Conversation Filters

There are two steps to using Node and Conversation display filter. Define the filter conditions,
and then apply the filter to the data set. The analyzer combines both filter definition and
application in one dialog.

1. Click the Display Filters icon ? on either the Protocol Navigator or the Frame Display
window or select "Apply/Modify Display Filters" from the filter menu to open the Set
Condition dialog box.

2. Choose "frames with the conversation" as the initial condition from the Select combo
box.

3. Select an address type from the Type combo box (The address type selection populates
both Address combo boxes with node address in the data set that match the type
selection).
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4. Select a node address from the first Address combo box.

Choose a direction arrow from the Direction box. The left arrow filters on all frames
where the top node address is the destination, the right arrow filters on all frames
where the top node address is the source, and the double arrow filters on all frames
where the top node address is either the source or the destination.

6. If you want to filter on just one node address, skip step 7 & 8, and continue with step 9.

7. If you want to filter on traffic going between two address nodes (i.e. a conversation),
select an address type for the second node address from the Type combo box.

8. Select a node address from the second Address combo box.

9. Click OK. The Set Condition dialog box closes and the analyzer applies the filter.
When a display filter is applied, a description of the filter appears to the right of the toolbar in
both the Protocol Navigator and the Frame Display windows.
Note:

The OK button is unavailable (grayed out) until the condition selections are complete.

Using Advanced Display Filtering Techniques

Intermediate to advanced users, with a solid knowledge of filter definition and application, may
find it useful to create some of the more common filters "on the fly" using the advanced filtering
techniques.

Choose one of the panes in either the Frame Display or Protocol Navigator windows:

1. Place the cursor over a parameter you wish to filter on such as a node address or
protocol type, and right click.

2. A pop up menu appears with selections for filtering.
Select the filter.

4. The system either closes the menu and applies the filter, or displays the Set Conditions
dialog box with the known parameters filled in and the additional options available to
complete the conditions statement.

Deleting and Hiding Display Filters
The Difference Between Deleting and Hiding Display Filters

If you wish to remove a filter from the system permanently, then use the Delete procedure.
However, if all you want to do is remove a filter as a means to un-clutter the display, then use
the Hide procedure.

Deleting a saved filter removes the filter from the current session and all subsequent sessions. In
order to retrieve a deleted filter, the user must recreate it using the Set Conditions dialog.

Hiding a filter merely removes the filter from the display. A hidden filter can be reapplied using
the Show/Hide procedure.
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Deleting Saved Display Filters

1. Select Delete Display Filters from the Filter menu in either the Protocol Navigator

or the Frame Display @window to open the Delete Named Condition dialog. The
system displays the Delete Named Condition dialog with a list of all user defined filters.

2. Select the filter to be deleted from the drop-down list.
Click the Delete button.
4. Click OK. The Delete Named Condition dialog box closes and the system deletes the
filter.
Hiding/Revealing a Display Filter
1. Select "Hide/Show Display Filters" from the filter menu on either the Protocol Navigator
or the Frame Display @window to open the Hide/Show dialog. The system
displays the Hide/Show dialog with a list of all user defined filters.
2. Select the filter to be hidden from the combo box.
Click the Hide button.
4. Click OK. The Hide/Show dialog box closes, and the system hides the filter and removes
the filter tab from the Frame Display.
Revealing a Hidden Display Filter

There are several ways to reveal a hidden filter. One can open the Quick Filter dialog and check
the box next to the hidden filter, or check the box next the hidden filter in the Protocol
Navigator display.

Perform the following actions to reveal a hidden filter:

1. Select "Hide/Show Display Filters" from the filter menu in either the Protocol Navigator
or the Frame Display @window to open the Hide/Show dialog. The system
displays the Hide/Show dialog with a list of all user defined filters.

2. Select the filter to be revealed from the combo box.

Click the Show button.

4. Click OK. The Hide/Show dialog box closes and the system reveals the filter and adds
the filter tab to the Frame Display.
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Editing Filters

Modifying a Condition in a Filter

Note:

Click the Display Filters icon ? on either the Protocol Navigator or the Frame

Display @window or select "Apply/Modify Display Filters" from the Filter menu to
open the Set Condition dialog box. The Set Condition dialog box displays the current
filter definition. To display another filter, click the Open icon, and select the filter from
the Popup list of all the saved filters.

Edit the desired parameter of the condition.

Because the required fields for a condition statement depend upon previously selected
parameters, the Set Condition dialog box may display additional fields that were not
present in the original filter. In the event this occurs, continue to enter the requested
parameters in the fields provided until the condition statement is complete.

Click OK. The system displays the Save Named Condition dialog. Ensure that the filter
name is displayed in the text box at the top of the dialog, and click OK. (If you choose to
create an additional filter, then provide a new name for the filter condition or accept
the default name provided by the system and click OK.) The Set Condition dialog box
closes, and the system applies the modified filter.

When a display filter is applied, a description of the filter appears to the right of the toolbar in
both the Protocol Navigator and the Frame Display windows.

The OK button on the Set Condition dialog box is unavailable (grayed out) until the condition
selections are complete.

Deleting a Condition in a Filter

oA N

Click the Display Filters icon ? on either the Protocol Navigator or the Frame Display
window or select "Apply/Modify Display Filters" from the Filter menu to open the Set
Condition dialog box. The Set Condition dialog box displays the current filter definition.
To display another filter, click the Open icon, and select the filter from the Popup list of
all the saved filters.

Select the desired condition from the filter definition.
Click the Delete icon.
Edit the Boolean operators and parentheses as needed.

Click OK. The system displays the Save Named Condition dialog. Ensure that the filter
name is displayed in the text box at the top of the dialog, and click OK. (If you choose to
create an additional filter, then provide a new name for the filter condition or accept
the default name provided by the system and click OK.) The Set Condition dialog box
closes, and the system applies the modified filter.
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Note:

When a display filter is applied, a description of the filter appears to the right of the toolbar in
both the Protocol Navigator and the Frame Display windows.

The OK button on the Set Condition dialog box is unavailable (grayed out) until the condition
selections are complete.

Renaming a Display Filter

1. Select "Rename Display Filters" from the Filter menu in either the Protocol Navigator
or the Frame Display @window to open the Rename Filter dialog. The system
displays the Rename Filter dialog with a list of all user defined filters.

2. Select the filter to be renamed from the combo box.
Enter a new name for the filter in the text box.

4. Click OK. The Rename Filter dialog box closes and the system renames the filter.

Protocol Filtering from the Frame Display

Easy Protocol Filtering

There are two types of easy protocol filtering. The first method lets you filter on the protocol
shown in the Summary pane, and the second lets you filter on any protocol discovered on the
network so far.

Filtering On the Summary Layer Protocol

To filter on the protocol in the Summary pane:
1. Select the tab of the desired protocol, or open the Summary Layer combo box
2. Select the desired protocol.

3. To filter on a different layer, just select another tab, or change the layer selection in the
combo box.

Quick Filtering on a Protocol Layer

1. Tofilter on any protocol layer, open either the Frame Display or Protocol Navigator
window.

2. Onthe Frame Display window, click the starred Quick Filtering icon ‘ﬁ or select
"Quick Filtering" from the Filter menu.
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This opens a dialog that lists all the protocols discovered so far. The box on the left shows the
protocols you can filter on.

3. Check the small box next to the name of each protocol you want to filter on, and then
click OK.

If you filter on more than one protocol, the results are all frames that contain at least one of
those protocols. For example, if you filter on IP and IPX NetBIOS, you receive all frames that
contain either IP or IPX NetBIOS (or both).

Quick filtering creates a tab on the Frame Display labeled Quick Filter. Changing the filter
definition on the Quick Filter dialog changes the filter applied on the Quick Filter tab. Quick
filters are persistent during the session, but are discarded when the session is closed.

Filtering on all Frames with Errors from the Frame Display

To filter on all frames with errors:

1. Open the Frame Display @window.

2. Click the starred Quick Filter icon g or select "Quick Filtering" from the Filter menu
Check the box for All Frames With Errors in the "Protocols to filter in" pane, and click OK.

4. The system creates a tab on the Frame Display labeled Quick Filter that displays the
results of the All Frames With Errors filter.

Protocol Filtering from the Protocol Navigator
Filtering on a Protocol Layer

You can filter on one or more protocol layers. The filter is inclusive which means only frames
containing that protocol are shown in the window. Frames that do not contain the protocol do
not appear. You can filter on one protocol or several. (Filtering on the Protocol Navigator
window is display filtering only.)

On the left side of the window are three panes. The top pane is the Filtering pane. In the pane is
a list of all the protocols seen so far on the circuit.

1. Check the boxes next to the names of the protocols you want to filter in.

Filtering on a protocol layer from the Protocol Navigator affects the contents of the Frame
Display window, and vice versa.

Three additional filters available are:
e All Frames With Bookmarks - filters in all frames with a bookmark associated with them.
e All Frames With Errors - filters in all frames with errors.

e All Special Information Nodes - filters in all special information nodes .
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Filtering on all Frames with Bookmarks

To filter on all frames with bookmarks:

1. Open the Protocol Navigator window.

2. Check the All Frames With Bookmarks box in the top pane on the left side of the
window.

3. Toremove the filter, un-check the box.
Filtering on all Frames with Errors from the Protocol Navigator
To filter on all frames with errors :

1. Open the Protocol Navigator window.
2. Check the All Frames With Errors box in the top pane on the left side of the window.

3. Toremove the filter, un-check the box.
Filtering on all Frames with Special Information Nodes
To filter on all frames with special information nodes:

1. Open the Protocol Navigator window.

2. Check the All Special Information Nodes box in the top pane on the left side of the
window.

3. Toremove the filter, un-check the box.

Named Filters

You can create, modify, and delete filters using the Filter menu items on the Protocol Navigator
and Frame Display dialogs.

If you create a Named filter using the Filters dialog, the filter appears in the Named Frame Filters
pane in the bottom left corner of the Protocol Navigator window.

1. Check the boxes next to the names of the filters you want to use.

Note that using a named filter affects the contents of the Frame Display window as well.
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Saving Data

You can save all or part of a capture file. You can also load a previously saved capture file, and
save a portion of that file to another file. This feature is useful if someone else needs to see only
a portion of the data in your capture file.

On the Control toolbar you can set up to capture a single file or series of files.

Saving the Entire Capture File with Save Selection

1. If you are capturing data, click on the Stop icon to stop data capture. You cannot
save data to file while it is being captured.

_,,,

2. Open the Event Display or Frame Display window.

Right click in the data

4. Select Save Selection from the right click menu

Save 0

() Entire File
(3} Selecton L

() Eventz () Frames

1 o |1

5l

Az | Tvpe fle name hed

Mote: Mo caphuring vall be done wide the
file is being sanved

5. Click on the radio button labeled Entire File.
6. Choose to save Events or Frames (see note below).

7. Type afilename in the Save As box at the bottom of the screen. Click the Browse icon to
browse to a specific directory. Otherwise your file is saved in the default capture file
directory.

8. When you are finished, click OK.

NOTE:
Choosing to save Events saves the entire contents of the capture file.

Choosing to save Frames does not save all events in the capture file.
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Saving a Portion of a Capture File

1. If you are capturing data, click on the Stop icon 8 to pause data capture. You cannot
save data to a file while it is being captured.

2. Open the Event Display ﬁ or Frame Display window @, depending on whether you
want to specify a range in bytes or in frames.

3. Select the portion of the data that you want to save. Click and drag to select data, or
click on the first item, move to the last item and Shift+Click to select the entire range, or
use the Shift key with the keyboard arrows or the navigation icons in the Frame Display
toolbar. If the range you want to save is too large to select, note the numbers of the first
and last item in the range.

4. Rightclick in the data

Select Save Selection from the right click menu

Save
() Entite Fila
Cancel
© Selecton N [_Concel ]
Help
TS, [_Hep |
1 o 1
&z | Type e name heid Q
Mole: No caphuring vall be dones wide the
filer is besng sanved

6. Click on the radio button labeled Selection. If you selected a range, make sure the
starting and ending numbers are correct. To specify a range, type the numbers of the
first and last items in the range in the boxes, and select either Events or Frames to
indicate whether the numbers are event or frame numbers.

7. Type afilename in the Save As box at the bottom of the screen. Click the Browse icon to
browse to a specific directory. Otherwise your file is saved in the default capture file
directory.

8. Click OK when you are finished.
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Saving the Entire Capture File using File>Save or the Save Icon

This option is only available when you select Single File from the Capture Mode on
System Settings.

1. If you are capturing data, click on the Stop icon 8 to pause data capture. You cannot
save data to a file while it is being captured.

Open the Event Display p or Frame Display window EI
Click the Save Icon or select Save from the File menu.

Type a file name in the File name text box at the bottom of the screen.

vk W

Browse to select a specific directory. Otherwise your file is saved in the capture file
directory.

6. Click OK when you are finished.
Confirm Capture File (CFA) Changes

This dialog appears when you close a capture file after changing the Notes, the protocol stack,
or bookmarks. The dialog lists information that was added or changed and allows you to select
which information to save, and whether to save it to the current file or to a new one.

The changes that you have made appear in a list in the left pane. Check the boxes next to the
changes you want to keep. Click on each item to see details in the right pane about what was
changed for each item.

e Save To This File — Saves the changes you have made to the current capture file.
e Save As — Saves the changes to a new file.

e Cancel the Close Operation — Cancels closing the file and returns you back to the display.
No changes are saved.

e Discard Changes — Closes the file without saving any of the changes made to the notes,
bookmarks, or protocol stack.

Adding Comments to a Capture File

The Notes feature allows you to add comments to a CFA file. These comments can be used for
many purposes. For example, you can list the setup used to create the capture file, record why
the file is useful to keep, or include notes to another person detailing which frames to look at
and why. (Bookmarks are another useful way to record information about individual frames.)

To open the Notes window :

1. Click the Show Notes icon —Pj . This icon is present on the toolbars of the Frame

Display EI, the Protocol Navigator , as well as the Event Display ﬁ . Notes can
be selected from the Edit menu on one of these windows.
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2. Type your comments in the large edit box on the Notes window. The Cut, Copy, Paste,
Undo and Redo features are all supported.

4

3. Click the thumbtack icon to keep the Notes window on top of any other windows.
4. When you're done adding comments, close the window.

5. When you close the capture file, you are asked to confirm the changes to the capture
file. See Confirming Capture File (CFA) Changes for more information.

Loading and Importing Capture Files
From the Control Window:
1. Go to the File menu.
2. Choose a file from the recently used file list.
3. If the file is not in the File menu list, select Open Capture File from the File menu or
simply click on the Open icon r_—-fj on the Toolbar.
4. Capture files have a .cfa extension. Browse if necessary to find your capture file.

5. Click on your file, and then click Open.

Importing Capture Files

1. From the Control Window @ , go to the File menu and select Open Capture File or
click on the Open icon on the Toolbar.

2. Change the Files of Type box to All Importable File Types or All Supported File Types.
Select the file and click Open.

The analyzer automatically converts the file to the analyzer's format while keeping the original
file in its original format. You can save the file in the analyzer's format, close the file without
saving it in the analyzer's format, or have the analyzer automatically save the file in the
analyzer's format (see the System Settings to set this option). All of these options keep your
original file untouched.

When you first open the file, the analyzer brings up the Protocol Stack window and ask you what
protocol decodes, if any, you want to use. You must choose a protocol decode at this point for
the analyzer to decode the data in the file. If you open a file without using any decodes, and
decide later that you want to apply a decode, choose Reframe from the File menu on the
Control window.

At present, the analyzer supports the following file types:

e Frontline Serialtest* Async and Serialtest ComProbe for DOS — requires the .byt for
data and the .tim for timestamps (see note on importing DOS timestamps).

e Greenleaf ViewComm* 3.0 for DOS - requires the .byt for data and the .tim for
timestamps (see note on importing DOS timestamps).
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e Frontline Ethertest* for DOS — requires 3 files: filename.cap, filename.ca0 and
filename.cal.

e Sniffer Type 1 — supports files with the .enc extension. Does not support Sniffer files
with a .cap extension.

e Snoop or Sun Snoop — files with a .cap extension based on RFC 1761. For file format, see
http://www.faqgs.org/rfcs/rfc1761.html.

¢ Shomiti Surveyor files in Snoop format —files with a .cap extension. For file format,
contact Technical Support.

e CATC Merlin - files with a .csv extension. Files must be exported with a specific format.
See File Format for Merlin Files for information.

e CATC Chief - files with a .txt extension.

Timestamps

Serialtest for DOS uses a timebase of Pacific Standard Time during non daylight savings time
hours and Pacific Daylight Time during daylight savings time hours. The analyzer always uses
Greenwich Mean Time (also known as Universal Time Coordinates).

When importing a Serialtest for DOS file, the analyzer must determine if the file was recorded
during daylight savings time or not before converting the timestamps. Because the rules for
determining this can change, it is possible for the analyzer to convert the timestamps
incorrectly, resulting in timestamps that are off by one hour.

Adding Comments to a Capture File

The Notes feature allows you to add comments to a CFA file. These comments can be used for
many purposes. For example, you can list the setup used to create the capture file, record why
the file is useful to keep, or include notes to another person detailing which frames to look at
and why. (Bookmarks are another useful way to record information about individual frames.)

To open the Notes window :

1. Click the Show Notes icon —H . This icon is present on the toolbars of the Frame
Display EI, the Protocol Navigator , as well as the Event Display ﬁ . Notes can
be selected from the Edit menu on one of these windows.

2. Type your comments in the large edit box on the Notes window. The Cut, Copy, Paste,
Undo and Redo features are all supported.

Click the thumbtack icon 4

to keep the Notes window on top of any other windows.
4. When you're done adding comments, close the window.

5. When you close the capture file, you are asked to confirm the changes to the capture
file. See Confirming Capture File (CFA) Changes for more information.
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Printing
Printing from the Frame Display

About Frame Display Print

The Frame Display Print feature provides the user with the option to print the entire capture
buffer or the current selection. When Print Preview is selected, the output displays in a browser
print preview window, where the user can select from the standard print options. The output
file format is in html, and uses the Microsoft Web Browser Control print options for background
colors and images
Print Background Colors Using Internet Explorer

1. Open the Tools menu on the browser menu bar

2. Select “Internet Options...” menu entry.

3. Click Advanced tab.

4. Check “Print background colors and images” under the Printing section

5

Click the Apply button, then click OK

Configure the Print File Range in the Frame Display Print Dialog

Selecting more than one frame in the Frame Display window defaults the radio button in the
Frame Display Print dialog to Selection and allows the user to choose the All radio button. When
only one frame is selected, the All radio button in the Frame Display Print dialog is selected.

How to Print Frame Display Data

1. Select Print or Print Preview from the File menu on the Frame Display window to display
the Frame Display Print dialog. Select Print if you just want to print your data to your
default printer. Select Print Preview if you want access to printer options.

Open Caplure File... Chri+0
Close

Frinkt Presvie., .. !

Redoad Decoders
Racrastes Cofmpanion Fils

2. Choose to include the Summary Pane (check the box) in the print output. The summary
Pane appears at the beginning of the printed output in tabular format.

3. Inthe Detail Section, choose to exclude the decode from the Detail Pane in the Frame
Display, or include All Layers or Selected Layers Only. If you choose to include selected
layers, then select (click on and highlight) the layers from the list box. Click on selected
layers in the list to de-select, or click the Reset button to de-select all selected layers.
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CAUTION: Decode layers printout expanded regardless of the state of the Detail Pane in the
Frame Display at the time of the request to print. This can produce a print output consisting of
hundreds of pages or more. We recommend that you use Print Preview to determine the
number of pages in your print output prior to printing.

Frame Display Print E]

Summary Sechion [retad Section
% Mo decods section

" Alllayers

™ Selected layers only

ARP -
Conbead Missing
Data

Event Rangs E:EWEDDTP

| Connns oo i

* Selection Reset Selected Lapers

W

Hobe: Browses prind opbions may affect whethes ary
gray backoeound is printed. Ses Help for indo.

Cacel | _Hob_|

4. Select the range of frames to include All or Selection in the Frame Range section of the
Frame Display Print dialog. Choosing All prints all of the frames in the capture file or
buffer. Choosing Selection prints only the selected frames in the Frame Display window.

Note: See Configure the Print File Range in the Frame Display Print Dialog above for an
explanation of these selections

5. Click the OK button.

6. If you chose Print Preview, the system displays your data in a browser print preview
display with options for printing such as page orientation and paper size. You can also
use your Printer Preferences dialog to make some of these selections. When printing
your data, the analyzer creates an html file and prints the path to the file at the bottom
of the page. This file can be opened in your browser, however, it may appear different
than the printed version.

Printing from the Event Display

About Event Display Print

The Event Display Print feature provides the user with option to print either the entire capture
buffer or the current selection. When Print Preview is selected, the output displays in a browser
print preview window, where the user can select from the standard print options. The output
file format is in html, and uses the Microsoft Web Browser Control print options print options
for background colors and images (see below).
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Print Background Colors Using Internet Explorer

1.
2.
3.
4.
5.

Open the Tools menu on the browser menu bar

Select “Internet Options...” menu entry.

Click Advanced tab.

Check “Print background colors and images” under the Printing section

Click the Apply button, then click OK

The Event Display Print feature uses the current format of the Event Display as specified by the

user.

Note: See About Event Display for an explanation on formatting the Event Display prior to
initiating the print feature.

Configure the Print File Range in the Event Display Print Dialog

Selecting more than one event in the Event Display window defaults the radio button in the
Event Display Print dialog to Selection and allows the user to choose the All radio button. When
only one event is selected (can’t have none selected), the All radio button in the Event Display
Print dialog is selected.

How to Print Event Display Data to a Browser

1.

2.

Select Print or Print Preview from the File menu on the Event Display window to display
the Event Display Print dialog. Select Print if you just want to print your data to your
default printer. Select Print Preview if you want access to printer options.

Open Capture File... 0
Close

Save AL, S
Export Events...

Achvanced Export Events. ..

Prirt Preview, ,, !

Select the range of events to include from either All or Selection in the Event Range

section of the Event Display Print dialog. Choosing All prints all of the events in the capture
file or buffer. Choosing Selection prints only the selected events in the Event Display
window.

Note: See Configure the Print File Range in the Event Display Print Dialog above for an
explanation of these selections

1/8/2008 Page 89 MeshDecoder-UM-002



frontlineg

Event Display Print x|
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3. Click the OK button.

If you chose Print Preview, the system displays your data in a browser print preview display with
options for printing such as page orientation and paper size. You can also use your Printer
Preferences dialog to make some of these selections. When printing your data, the analyzer
creates an html file and prints the path to the file at the bottom of the page. This file can be
opened in your browser, however, it may appear different than the printed version.

1/8/2008 Page 90 MeshDecoder-UM-002



frontlineg

Exporting
Quick Export

You can dump the contents of the Summary pane on the Frame Display into a Comma Separated
File (CSV).

To access this feature:
e Right click on the Summary Pane
e Select the Export menu item
Another option to access quick exportis :
e Click on the File menu

e Choose Export Summary.
Exporting Data
Exporting Event Display to a File

About Event Display Export

The Event Display Export feature provides the following options:
e Export either the entire capture buffer or the current selection
e Output file format as text, CSV, html, or bin.

The Event Display Export feature uses the current format of the Event Display as specified by the
user.

Note: See About Event Display for an explanation on formatting the Event Display prior to
initiating the export feature.
Accessing the Event Display Export Dialog

Selecting Export Events... from the File menu in the Event Display brings up the following dialog:

Event Display Export El
File nussnes: [:]
Save as lype: v

Everd rangs Side:
OF] (0 Both
() Sabection = DTE
O DCE
| save || Cacel |[ Heo |

Configure the Export File Range in the Event Display Export Dialog

Selecting more than one event in the Event Display window defaults the radio button in the
Event Display Export dialog to Selection and allows the user to choose the All radio button.
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When only one event is selected (something must be selected), the All radio button in the Event
Display Export dialog is selected by default.

Side is used to determine whether you want to export data from a DCE device, DTE device or
both.

How to Export Event Display Data to a File

1. Select Export Events... from the File menu on the Event Display window to display the
Event Display Export dialog.

2. Enter afile path and name, or click the browser button to display the Windows Save As
dialog and navigate to the desired storage location.

3. Select a file type from the Save as type: drop-down List Menu on the Event Display
Export dialog.
Select from among the following file formats:
Text File (*.txt)

CSV File (*.csv)

HTML File (*.html)

Binary File (*.bin)
4. Select the range of events to include in the file from either All or Selection in the Event
Range section of the Event Display Export dialog.
Note: See Configure the Export File Range in the Event Display Export Dialog above for an
explanation of these selections.

5. Click the Save button.
Export Filter Out

You can filter out data you don't want or need in your text file.

(This option is available only for serial data.) In the Filter Out box, choose which side to filter out:
the DTE data, the DCE data or neither side (don't filter any data.) For example, if you choose the
radio button for DTE data, the DTE data would be filtered out of your export file and the file
would contain only the DCE data.

You can also filter out Special Events (which is everything that is not a data byte, such as control
signal changes and Set I/O events), Non-printable characters or both. If you choose to filter out
Special Events, your export file would contain only the data bytes. Filtering out the non-
printable characters means that your export file would contain only special events and data
bytes classified as printable. In ASCII, printable characters are those with hex values between
$20 and $7e.

Exporting Baudot
When exporting Baudot, you need to be able to determine the state of the shift character. In a

text export, the state of the shift bit can be determined by the data in the Character field. When
letters is active, the character field shows letters and vice versa.
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Other Export Options

Use Footer

Use
Abbreviated
Event
Names

Separate
Records
with CR/LF

Align
Columns

Put Fields in
Double
Quotes

Output
Header

Output
Field Name
Record

Align Field
Names with
Data

Timestamp
Format

Character
Set

Signals
Characters

Errors
Characters

Field
Delimiter

1/8/2008

This option is valid only when doing a binary export. If you are
exporting a capture file for the purpose of re-transmitting the data,
un-check this box. If you are going to be manipulating the data using
the sample export program, check this box. If the data is exported
without the footer, the sample export program is not able to read the
export file.

Check this box to abbreviate the names of the Special Events. This is
useful to conserve space in the text file.

Specifies whether to separate each record with a carriage return/line
feed. If this option is unchecked, the data is output as a continuous
stream.

Check this box to have the columns be left-justified.

Check this box to put double quotes around the data in each field.

Includes a header at the top of the file with the date and time the file
was exported, name of the original capture file or capture buffer, and
the event numbers and timestamps for the range exported.

Includes a record at the top of the file with the field names.

Aligns the field name column with the data columns.

Sets the timestamp format. Native format is the month/day/year plus
hour:minute:second:millisecond AM/PM in twelve hour format For
other formats, "D" stands for day, "H" stands for hour, "M" stands for
minute, "S" stands for second and "m" stands for millisecond.

Choose ASCII, EBCDIC or Baudot. (See note on exporting Baudot.)

Defines how control signal states are indicated. Choose from 1/0, T/F,
or X/space. "X", "1" and "T" indicate an "on" or "high" signal state.

Defines how error conditions are indicated. Choose from 1/0, T/F, or
X/space. "X", "1" and "T" indicate that an error occurred.

Defines how the fields are separated. Choices are None (no delimiter
is used), Comma, Tab, Space, Bar and Semicolon. If a delimiter is
chosen, the analyzer includes the delimiter between each field in the
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export file.

Saving Export Templates

Once you have set up an export format, you can save all your options as a template and use it
for future exports.

1.

To create a template, set up all the options on the export window exactly as you want
them to be in the template.

Type a name in the Apply Template box, and click Save Template.

To retrieve your template, click on the down arrow next to the Apply Template box, and
choose your template from the list.

To delete a template, choose the template in the Apply Template box, and click the
Delete Template button. There are several templates supplied with the analyzer that
cannot be deleted.
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System Settings and Program Options

System Settings

Open the System Settings window by choosing System Settings from the Options menu on the
Control window. To enable a setting, click in the box next to the setting to place a checkmark in
the box. To disable a setting, click in the box to remove the checkmark. When viewing a capture
file, settings related to data capture are grayed out.

Common Options

File Options

Note:

Wrap File

When enabled, the analyzer wraps the file when it becomes full. The oldest
events are moved out of the file to make room for new events. Any events
moved out of the file are lost. When disabled, the analyzer stops capture when
the file becomes full. Either reset the file or close your capture file to continue.

Restart Capturing After 'Close Capture File'

If the Automatically Restart feature is enabled, the analyzer restarts capture to
the file immediately after the file is closed.

Start up

Opens the Program Start up Options window. Start up options let you choose
whether to start data capture immediately on opening the analyzer.

Advanced

Opens the Advanced System Options window. The Advanced Settings should
only be changed on advice of technical support.

File Size (in K)

Enter the maximum size of the capture file. If you enter a number larger than
the maximum allowable size, the analyzer will display the allowable sizes.

In both cases, these values are dependent on available system resources and may be adjusted
according. The analyzer limits the maximum size of file to 50% of available memory or disk

space.

Series of files

This option lets you capture to a series of files. The size of each file is no larger than the
number given in File Size (in K) which has a maximum limit of 100013KB. The name of
each file is the name you give it in the Name box followed by the date, time and a
number. The date and time are when the series was opened. The number increments
with each file. This guarantees unique file names are created.

Set the maximum number of files in the series in the Maximum number of files box. The
next file starts when the currently open file is full. If you want to start a new file on a
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periodic basis, check the box for Start new file after and put in the number of hours
after which a new file is started. Note that if the currently open file becomes full before
the time limit has been reached, a new file is opened immediately rather than lose data.

Capturing stops if the maximum number of files has been used unless Wrap Files has
been checked. If Wrap Files has been checked the analyzer erases the oldest file in the
series and make a new file.

e Single File

This option allows the analyzer to capture data to a file without prompting you for a file
name each time. The size of each file are not larger than the number given in File Size
(in K). The name of each file is the name you give it in the Name box followed by the
date and time. The date and time are when the series was opened.

Accessing Advanced System Options

These parameters affect fundamental aspects of the software, and it is unlikely that you ever
have to change them. If you do change them and need to return them to their original values,
the default value is listed in parentheses to the right of the value box.

Most technical support problems are not related to these parameters, and as changing them
could have serious consequences for the performance of the analyzer, we strongly recommend
contacting technical support before changing any of these parameters.

To access the Advanced System Options:

1. Go to the Control @ window.
2. Choose System Settings from the Options menu.

3. On the System Settings window, click the Advanced button.

e Driver Receive Buffer Size in Kbytes

This is the size of the buffer used by the driver to store incoming data. This value is
expressed in Kbytes.

e Driver Action Queue Size In Operating System Pages

This is the size of the buffer used by the driver to store data to be transmitted. This
value is expressed in operating system pages.

e Frame Completion Timeout in Seconds

This is the number of seconds that the analyzer waits to receive data on a side while
in the midst of receiving a frame on that side.

If no data comes in on that side for longer than the specified number of seconds, an
"aborted frame" event is added to the Event Display and the analyzer resumes
decoding incoming data. This can occur when capturing interwoven data (DTE and
DCE) and one side stops transmitting in the middle of a frame.

Aborted frames (just like broken frames and regular frames) are decoded and
displayed in the Frame Display. If you experience aborted frames and suspect that
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your framed data may have pauses in it that exceed the specified timeout time,
then you may want to increase that value.

The range for this value is from 0 to 999,999 seconds. Setting it to zero disables the
timeout feature.

Changing Default File Locations

The analyzer puts user files in specific locations by default. Capture files are placed in the My
Capture Files directory and configurations are put in My Configurations. Follow the steps below
to change the default locations.

2
3
4.
5

Choose Directories from the Options menu on the Control @ window to open the File
Locations window.

Select the default location you wish to change.
Click Modify.

Browse to a new location. Click OK.

Click OK when finished.

Default Capture File Folder Checkbox

If the “Use Last Opened Folder for Capture Files” checkbox is checked, then the system
automatically changes the default directory for capture files each time you save a file to a
different directory. If the checkbox is unchecked, then the system always defaults to the
directory listed in the File Locations dialog.

Selecting Start Up Options
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To open this window:

1. Choose System Settings from the Options menu on the Control @ window.
2. On the System Settings window, click the Start Up button.

3. Choose one of the options to determine if the analyzer starts data capture immediately
on starting up or not.

Don't start capturing immediately.

This is the default setting. The analyzer begins monitoring data but does not begin capturing

data until the Start Capture & icon on the Control, Event Display or Frame Display windows is
clicked.

Start capturing to a file immediately.

When the analyzer starts up, it immediately opens a capture file and begin data capture to it.

This is the equivalent of clicking the Start Capture & icon. The file is given a name based on
the settings for capturing to a file or series of files in the System Settings window.

Start capturing immediately to the following file:

Enter a filename in the box below this option. When the analyzer starts up, it immediately
begins data capture to that file. If the file already exists, the data in it is overwritten.

Names

The system uses a variety of industry standard names for objects and events that appear in

various displays.

To access the Names dialog, click the Names button on the 1/0 Settings window %, or choose
Names from the Options menu on the Control window. Changes to the Names are used
throughout the program.

To change a name, click on the name given in the current column, and then click again to modify
the name (a slow double-click). To restore the default values, click the Defaults button. The
names used in the system fall into one of three general categories.

Because of variations associated with different types of communications, the Names dialog may
display all or only a subset of the following categories:

e Sides

The Sides section allows you to give each side on a network more descriptive names.
This is useful on network with more than one side.

e Errors

This section allows you to change the error names. The errors listed are appropriate for
the type of circuit/network you are monitoring.

e Signals
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Signals refers to the six control signals used in RS-232 data communications, and may
not apply to the type of communications you are monitoring.
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Timestamping

Timestamping Options

The Timestamping Options window allows you to enable or disable timestamping, and change
the resolution of the timestamps for both capture and display purposes.

To open this window :

Choose System Settings from the Options menu on the Control window.
Click the Timestamping Options button.
OR

Click the Timestamping Options icon from either the Event Display or Statistics
window.

Enabling/Disabling Timestamping

1. Choose System Settings from the Options menu on the Control window, and click the

Timestamping Options button, or click the click the Timestamping Options icon

from either the Event Display ﬁ or Statistics H] window.

Check the Store Timestamps box to enable timestamping. Remove the check to disable
timestamping. If you disable timestamping, you are not able to do delta or rate
calculations.

Switching Between Relative and Absolute Time

With Timestamping you can choose to employ Relative Time or Absolute time.

1.

Choose System Settings from the Options menu on the Control window, and click the

Timestamping Options button, or click the click the Timestamping Options icon

from either the Event Display p or Statistics H] window.

Go to the Display Options section at the bottom of the window and find the Display
Relative Timestamps checkbox.

Check the box to switch the display to relative timestamps. Remove the check to return
to absolute timestamps.

Display Relative Timestamps shows the timestamp as the amount of time that has passed since
the first byte was captured. It works just like a stop watch in that the timestamp for the first
byte is 0:00:00.0000 and all subsequent timestamps increment from there. The timestamp is
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recorded as the actual time, so you can flip back and forth between relative and actual time as
needed.

The options in this section affect only how the timestamps are displayed on the screen, not how
the timestamps are recorded in the capture file.

Changing the Timestamping Resolution

This option affects the resolution of the timestamp stored in the capture file. The default
timestamp is 10 milliseconds. This value is determined by the operating system and is the
smallest "normal" resolutions possible.

It is also possible to use "high resolution" timestamping. High resolution timestamp values are
marked by an asterisk as high resolution in the drop down list.

To change timestamping resolutions:

1. Choose System Settings from the Options menu on the Control @ window, and click
the Timestamping Options button, or click the click the Timestamping Options icon

from either the Event Display p or Statistics H] window.

2. Go to the Capture Options section of the window.

3. Change the resolution listed in the Storage Resolution box. Note that if you change the
resolution, you need to exit the analyzer and restart in order for the change to take
effect.

Displaying Fractions of a Second

1. Choose System Settings from the Options menu on the Control @ window, and click
the Timestamping Options button, or click the click the Timestamping Options icon

from either the Event Display p or Statistics H] window.

2. Go to the Display Options section at the bottom of the window, and find the Number of
Digits to Display box.

3. Click on the arrows to change the number. You can display between 0 and 6 digits to the
right of the decimal point.

The options in this section affect only how the timestamps are displayed on the screen, not the
resolution used to capture the data.

Timestamps
Serialtest for DOS uses a timebase of Pacific Standard Time during non daylight savings time

hours and Pacific Daylight Time during daylight savings time hours. The analyzer always uses
Greenwich Mean Time (also known as Universal Time Coordinates).

1/8/2008 Page 101 MeshDecoder-UM-002



frontlineg

When importing a Serialtest for DOS file, the analyzer must determine if the file was recorded
during daylight savings time or not before converting the timestamps. Because the rules for
determining this can change, it is possible for the analyzer to convert the timestamps
incorrectly, resulting in timestamps that are off by one hour.

Performance Issues For High Resolution Timestamps

There are two things to be aware of when using high resolution timestamps. The first is that
high resolution timestamps take up more space in the capture file because more bits are
required to store the timestamp. Also, more timestamps need to be stored than at normal
resolutions. The second issue is that using high resolution timestamping may affect performance
on slower machines

For example, if 10 bytes of data are captured in 10 milliseconds at a rate of 1 byte per
millisecond, and the timestamp resolution is 10 milliseconds, then only one timestamp needs to
be stored for the 10 bytes of data. If the resolution is 1 millisecond, then 10 timestamps need to
be stored, one for each byte of data. If you have two capture files, both of the same size, but
one was captured using normal resolution timestamping and the other using high resolution,
the normal resolution file has more data events in it, because less room is used to store
timestamps.

You can increase the size of your capture file in the System Settings.
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Technical Information
Contacting Technical Support

Technical support is available in several ways. The online help system provides answers to many
user related questions. Frontline's website has documentation on common problems, as well as
software upgrades and utilities to use with our products.

On the Web: http://www.fte.com and click Support
Email: tech_support@fte.com

If you need to talk to a technical support representative, support is available between 9am and
5pm, U.S. Eastern time, Monday through Friday. Technical support is not available on U.S.
national holidays.

Phone: +1 (434) 984-4500
Fax: +1(434) 984-4505

The following information is provided to assist you with troubleshooting problems with this
analyzer.

Performance Notes

Contacting Technical Support

Miscellaneous Helpful Information
ASCII Codes

EBCDIC Codes

Baudot Codes

Communication Control Characters
Performance Notes

As a software-based product, the speed of your computer’s processor affects the analyzer’s
performance. Buffer overflow errors are an indicator that the analyzer is unable to keep up with
the data. The information below describes what happens to the data as it arrives, what the error
means, and how various aspects of the analyzer affect performance. Also included are
suggestions on how to improve performance.

The analyzer's driver takes data from the driver and counts each byte as they are put into the
driver’s buffer. The analyzer's driver tells the user interface that data is ready to be processed.
The analyzer takes the data from the driver’s buffer and puts the data into the capture buffer.

Driver Buffer Overflows occur when the user interface does not retrieve frames from the driver
quickly enough. Buffer overflows are indicated in the Event Display window by a plus sign within
a circle. Clicking on the buffer overflow symbol displays how many frames have been lost. The
Statistics window is a good place to check for buffer overflow errors.

There are several things that you can do to try and solve this problem.
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e Use capture filters to filter out data you don't need to see. Capture filters reduce the
amount of data processed by the analyzer. (Ethernet Only)

e Close all other programs that are doing work while the analyzer is running. Refrain from
doing searches in the Event Display window or other processor intensive activities while
the analyzer is capturing data.

e Timestamping takes up processor time, primarily not in timestamping the data, but in
writing the timestamp to the file. Try turning off timestamping from the Timestamping
Options window.

e For Driver Buffer Overflows, change the size of the driver buffer. This value is changed
from the Advanced System Settings. Go to the Control Window and choose System
Settings from the Options menu. Click on the Advanced button. Find the value Driver
Receive Buffer Size in Operating System Pages. Take the number listed there and double
it.

e The analyzer’s number one priority is capturing data; updating windows is secondary.
However, updating windows still takes a certain amount of processor time, and may
cause the analyzer to lose data while the window is being updated. Some windows
require more processing time than others because the information being displayed in
them is constantly changing. Refrain from displaying data live in the Event Display and
Frame Display windows. Try closing the Statistics windows. The analyzer can capture
data with no windows other than the Control window open.

e If you are still experiencing buffer overflows after trying all of the above options, then
you need to use a faster PC.

Changing Where the Search Lands

When doing a search in the analyzer, the byte or bytes matching the search criteria are
highlighted in the Event Display. The first selected byte appears on the third line of the display.

To change the line on which the first selected byte appears:
1. Open fts.ini (located in the C:\Program Files\Common Files\FTE)
2. Go to the [CVEventDisplay] section
3. Change the value for SelectionOffset.
4

If you want the selection to land on the top line of the display, change the
SelectionOffset to 0 (zero).

Progress Bars

The analyzer uses progress bars to indicate the progress of a number of different processes.
Some progress bars (such as the filtering progress bar) remain visible, while others are hidden.

The title on the progress bar indicates the process underway.
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Event Numbering

This section talks about how events are numbered when they are first captured and how this
affects the display windows in the analyzer. The information in this section applies to frame
numbering as well.

When the analyzer captures an event, it gives the event a number. If the event is a data byte
event, it receives a byte number in addition to an event number. There are usually more events
than bytes, with the result is that a byte might be listed as Event 10 of 16 when viewing all
events, and Byte 8 of 11 when viewing only the data bytes.

The numbers assigned to events that are wrapped out of the buffer are not reassigned. In other
words, when event number 1 is wrapped out of the buffer, event number 2 is not renumbered
to event 1. This means that the first event in the buffer may be listed as event 11520 of 16334,
because events 1-11519 have been wrapped out of the buffer. Since row numbers refer to the
event numbers, they work the same way. In the above example, the first row would be listed as
2d00 (which is hex for 11520.)

The advantage of not renumbering events is that you can save a portion of a capture file, send it
to a colleague, and tell your colleague to look at a particular event. Since the events are not
renumbered, your colleague’s file use the same event numbers that your file does.

Useful Character Tables

ASCII Codes

hex| *0 | x1 | «2 | x3 | =4 | x5 | o6 | x7 | xB | =9
Ox |MUL[SOH]| STX | ETX |[EQOT|ENQIACK|BEL| BS | HT | LF | WT | FF | CR | S0 [ SI
1x |DLE|DC1|DC2|DET | DCY |NAKISYN| ETB | CAN| EM |SUB|ESC| FS | S | RS | US

. ]

)

I

L

i

i

2x | 5P
x| 0
4 | &
Sx P
Bx )
7x p

= (o |m|m|rs

« [=|=||m]|e=

£ = 2|~ -

w |=r |||

ra b=

iz =|=|v
o

b o 20 I | = | =
Col Dl (] fa ] 2
= e | = O |
C o [S|m|th]a&
b | e b= |

=] =] & |
s [ = W |
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Baudot Codes

[DEC [ HEX | LETTERS | FIGURES |

0 00 | BLANK (NUL)| BLANK (MUL)

1 01 E a

2 02 LF LF

3 03 A .

4 04 P SP

5 05 S EBEL

[3 06 ] 8

T a7 I 7

8 08 CR CR

E] ] i] §

10 | 0A R 4

11 0B J '

12 oc M i

13 | 0D F ]

14 | OE ¢ :

15 | OF K {

16 10 T 5

17 [ 11 F4 .

18 | 12 L )

19 13 W 2

20 14 H #

21 15 Y [

2 16 [ [i]

23 17 Q 1

24 18 0 8

% | 19 B 7

% 14, €] &

rri 1B FIGURES FIGURES

28 1C [

24 10 X !

30 1E W N

Kl 1F LETTERS LETTERS
EBCDIC Codes

hex] 0 | 21 | 62 | 63 | 2d [ o6 | w6 | =7 [ B | 8 | wA [ xB | 2C | xD XE | xF
Ox |MUL[SOH| ST ET¢| PF | HT | LC | DEL SWMM VT |FFICR | S0 | S
1x JOLE(DC1DC2| T [RES| ML 1 BS | IL JCAN]EM | CC JCUT]IFS | IGS | IRS [ IUS
2x | DS [SOS]| FS BYP| LF |ETB|ESC SM | CL2 |ENQ|ACK]| BEL
3x SYN| PH | RS | UC |EQT CLT | DC4 | WAK SUB
4x | SP . < { *

Sx | & I $1 "1 R A
Bx | - | / 1. % > | 7
7x T # (@ = | -
Bx ] b d i@ f q b i

Sx i k | m | n o |l p| g r

Ax = 5 t u | v | w X y z |

Bx 1

Cx] { |A|lB|C|O|E|F|G[H]I

Dz|l I |JIK|L|IM|NIO|P|GQI|R

Ex | S| TlU ]|V W] X Ll 4

Fx| O 1 2 3 4 5 5] 7 8 9
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Communication Control Characters

Listed below in alphabetical order are the expanded text meanings for common ANSI
communication control characters, and two-character system abbreviation for each one. Some
abbreviations have forward slash characters between the two letters. This is to differentiate the
abbreviations for a control character from a hex number. For example, the abbreviation for
Form Feed is listed as F/F, to differentiate it from the hex number FF.

Abbreviation Control Text
Character

AK ACK Acknowledge

BL BEL Bell

BS BS Backspace

CN CAN Cancel

CR CR Carriage
Return

D/1-4 DC1-4 Device
Control 1-4

D/E DEL Delete

DL DLE Data Link
Escape

EM EM End of
Medium

EQ ENQ Enquiry

ET EOT End of
Transmission

E/C ESC Escape

E/B ETB End of
Transmission
Block

EX ETX End of Text

F/F FF Form Feed

FS FS File
Separator

GS GS Group
Separator

HT HT Horizontal
Tabulation

LF LF Line Feed

NK NAK Negative
Acknowledge

NU NUL Null

RS RS Record
Separator
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Sl Sl Shift In

SO SO Shift Out

SH SOH Start of
Heading

SX STX Start of Text

SB SUB Substitute

Sy SYN Synchronous
Idle

us us Unit
Separator

VT VT Vertical
Tabulation

Frame Decoder

Frame Decoder is for the development of add-on components to extend the functionality of
your FTS protocol analyzer. Those add-on components are generally used to decode existing or
custom protocols. The core of each such “decoder” is a program that defines how the protocol
data are to be broken up into fields and displayed in the Frame Display window of the analyzer
software. The DecoderScript Manual provides instruction on how to create custom decoders
and use them just like any of the decoders supplied with the protocol analyzer. You can also
apply this knowledge to modify decoders supplied with the protocol analyzer.

For more information about Frame Decoder, consult the DecoderScript Manual located in the
desktop folder under Optional Components, or simply select Start | Programs | Frontline
[Product Name and Version Number] | Optional Components | DecoderScript Manual.
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